WordPress.org

Forums

[resolved] Pages displaying using single.php instead of page.php (7 posts)

  1. Daniel.uww
    Member
    Posted 3 years ago #

    I'm building a template with the Thematic framework and certain "Pages" aren't displaying using the page.php template and instead are using single.php.

    This only happens on pages I have assigned to a parent page.

    The body class the pages get is-
    class="single single-page postid-41 logged-in admin-bar windows chrome ch"

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Thematic has its own support forum at http://themeshaper.com/forums/

  3. Daniel.uww
    Member
    Posted 3 years ago #

    I switched to the default WP theme and I still have this issue, so I don't think it's related to Thematic.

  4. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Do you have a live link to the site in question?

    Those classes are post classes, not page classes. If the page in question were a static page, it would have classes like:

    page page-id-172 page-child parent-pageid-173 page-template-default

    So, I really think you're looking at a single blog post, not a static page.

  5. Daniel.uww
    Member
    Posted 3 years ago #

    Thanks for you input Chip.
    Unfortunately I can't provide a link to the site.

    But, I assure you they are all pages that have been added as child items to other pages. I have 0 post created in this site and 10 pages, with 3 of them being child pages.

    Screenshot of Pages list in backend

  6. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Interesting.

    The next step would be to find out what's filtering the body classes. Are you using the latest version of Thematic? Are you using any Plugins that might be filtering body classes? What version of WordPress are you using?

    (Just trying to cover all the bases.)

    EDIT:

    Oh, also: look for anything that might be modifying the query, in addition to anything filtering body_class directly.

  7. Daniel.uww
    Member
    Posted 3 years ago #

    Ok I figured it out!

    It was an issue with the WP-Property plugin that I'm using.

    There is an option for this plugin to set the "Default Properties Page". You can set this option to one of your static pages, or use the default option which is internal to the plugin.

    I had it set to use the Parent Page of the 3 pages I was having the issue with. For some reason any child pages are set as post when this option is set to anything other than the default.

Topic Closed

This topic has been closed to new replies.

About this Topic