WordPress.org

Support

Support » How-To and Troubleshooting » Pages created result in dead links (404 error) – related to permalink settings

Pages created result in dead links (404 error) – related to permalink settings

  • Hello everyone,

    I’m new to WordPress and I’m having a problem when I create pages on my site. I ran this by someone I work with who has lots of WP experience and he couldn’t figure it out, so I’m hoping someone here can 🙂

    I would rather not have the “default” permalink setting. I changed it to /%postname%/ – as many people do – both for aesthetics and SEO reasons.

    Ever since doing that, whenever I create a new page, it results in a dead link. I create a page – e.g. “Music” – then hit Publish, then View Page from the page editing screen. It takes me to a 404 Not Found error page.

    When I switch back to “default” permalinks setting, the new pages I create and publish work just fine.

    It was recommended that I try deactivating plugins to see if that would solve the problem. I have 15-20 plugins. I have deactivated all of the plugins, but the problem persists.

    It was also suggested I try using a different theme to see if that would fix it (I have been using Flexibility 3). I tried a new theme, but no luck. The problem is still there.

    I would greatly appreciate your help. Any ideas? I’m sure a solution is right around the corner and it will no doubt be a huge relief after slogging away over the last few days trying to work this out.

    Thanks!
    Ed

Viewing 3 replies - 1 through 3 (of 3 total)
  • are you sure mod_rewrite is enabled on the server?

    I’m not sure where to check to find out. Can you point me in that direction? Does this relate to what OS I’m using (which is Windows XP, SP3) or some other factor – such as the hosting provider (which is HostGator)?

    Do you know of a post in the forum that explains what I would need to do to determine the answer and make sure it is enabled?

    Thanks for your reply

    http://codex.wordpress.org/Using_Permalinks

    I had the same problem when changed to the “Pretty Permalinks”

    It was my .htaccess file that I needed to edit

    That link above helped me a lot! Look for the part for “Creating and editing (.htaccess)” and read from there.

    Hope that helps

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Pages created result in dead links (404 error) – related to permalink settings’ is closed to new replies.
Skip to toolbar