WordPress.org

Forums

W3 Total Cache
Pages aren't caching properly (6 posts)

  1. Nik
    Member
    Posted 2 years ago #

    At certain times each hour, pages on my site won't fully load. I assume it's an issue with cache preload - I'm currently using 600 seconds at 12 pages per interval on shared hosting.

    I've tried changing this to 900 seconds at 10 pages per interval and other variables but seems to make things worse.

    Any suggestions?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. bheadrick
    Member
    Posted 2 years ago #

    using advanced or basic caching?

  3. Vijay Padiyar
    Member
    Posted 2 years ago #

    I am facing a similar issue. My website's WordPress installation is in the /cms subfolder under website root.

    However, the cache html file generated by W3-Total-Cache removes the /cms part from all page resources (css, js, etc.), which is causing 404 errors for these files and therefore pages are not displaying properly.

    I am attaching the index.html_ file from my w3tc/pgcache folder. As you can see from it, all .js, .css files etc. are being included as http://www.vijaypadiyar.in/wp-content/<path-to-file>; instead of http://www.vijaypadiyar.in/cms/wp-content/<path-to-file>. As a result, my home page is messed up (see attached image).

    Link to index.html_ generated by w3tc: https://docs.google.com/open?id=0B3fAqJpOwcyxcXNqa2NjTW5sOHM

    Image of home page when problem occurs: https://docs.google.com/open?id=0B3fAqJpOwcyxeTFxMlF0a2N4QkE

    Surprisingly, this seems to be happening only for the home page and not for other pages on my site. Also, it does not happen if I am logged in and viewing the uncached version of my site (I have disabled caching for logged-in users). Nor am I seeing the issue (yet) after disabling the W3-Total-Cache plugin.

    This issue has started only since the last few days. I am not sure if nickrag's issue is the same.

    Thanks

    Vijay

  4. Vijay Padiyar
    Member
    Posted 2 years ago #

    I also noticed these errors when I try to update settings in "Browser Cache" tab. Not sure if it is related to this issue.

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    However, I checked my root folder .htaccess and it looks fine. The w3tc rules are all present and above the WordPress rules.

    Regards

    Vijay

  5. Nik
    Member
    Posted 2 years ago #

    @bheadrick I'm using advanced caching

  6. bheadrick
    Member
    Posted 2 years ago #

    I've noticed many times that although advanced cache is available, your host doesn't actually meet the requirements for it, so it just doesnt work. Though, it's odd that it would only be working sporadically.
    Have you tried basic cache?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags