WordPress.org

Support

Support » How-To and Troubleshooting » Page/Post Author option “Admin” not available

Page/Post Author option “Admin” not available

  • ynab-wordpress
    Member

    @ynab-wordpress

    I am the admin and I have two other users that are classified as contributors: Contributor A and Contributor B. When I, as admin, go to write a post/page the author defaults to Contributor B and my only other option is to choose Contributor A. There is no option to choose the Admin as the author.

    In posts that I’d written prior to bringing on Contributor B, admin was an option.

    Also, all posts and pages written by the admin are still showing as such.

Viewing 15 replies - 1 through 15 (of 26 total)
  • Same problem EXACTLY for me. I added my self as an author (so I have me as admin and me as author). Then I write the post as Author and delete it. When deleting it asks, “Do you want to replace this name with Admin?” and I reply YES and it puts me on the post. Still, I read it was a bug in the new wordpress. Maybe someone will see these posts.

    Sometimes it helps if you give yourself a “nickname” in the Users > Your profile subpanel.

    designsimply
    Member

    @designsimply

    I think you need to make sure you have a display name field set. I tried deleting mine, and I had the same problem where admin was not listed as an author choice. Actually, I think the author choice is still there, but since there’s no display name, it just looks like a blank choice. Anyway, you can probably fix this by making sure the admin user has all the information filled out in the Name section of the user profile. You can double check this in your database by making sure the display_name field in the wp_users table has a value.

    ynab-wordpress
    Member

    @ynab-wordpress

    Yeah, my whole admin profile is filled out (nickname as well), so it’s not that.

    @markhuss – you mean you delete the author every time? Then re-create it again?

    Another solution for this in the past has been to create a new user with adminstrator role (e.g. ‘newadmin’), delete the ‘admin’ user and assign all posts to the ‘newadmin’ user. Then if necessary create ‘admin’ again and then delete the ‘newadmin’ user you created before, and assign the posts again to ‘admin’

    This is definitely a bug. I am exactly in the same situation. I use my blog kind of like a forum, where everyone can post (we are a translation team). Then this bug appears. I went to WordPress Codex and I got this:

    Post Author
    A list of all blog authors you can select from to attribute as the post author. This section only shows if you have multiple users with authoring rights in your blog.

    At first I thought this was unreasonable of the coders to “force” the admin not be able to write anymore in this case. But now I think this may be a mistake.

    Really want a way to fix this. Creating another account to “pour” the later posts into it is not a solution!!!

    I’m having the same problem as well. I’m the admin and one of the major contributors to my blog (along with 2 other editors), but all my posts are showing up as authored by one of the editors. I could and probably in the interim WILL create a separate “editor” account for myself, but am hoping the good WordPress folks can get a fix for this soon. Thanks!

    UncleMitch
    Member

    @unclemitch

    Try this solution:

    Create another profile for yourself with a name that shows up first alphabetically (e.g., 1admin). When you create a post, authorship will default to this user.

    but will WordPress fix this in future versions? No word from the admin in this topic.

    mickmel
    Member

    @mickmel

    It still seems to be a bug in 2.6.1, but there is a pretty easy fix.

    1. Create a new user and give them admin rights.
    2. Log-in as that new user.
    3. While logged in with them, change your main admin account to “subscriber” and save it.
    4. Now change your main admin account back to “administrator”.

    That should do it!

    ndna
    Member

    @ndna

    I think coders should find a way to fix this instead of making their 1000000… users do this manually (as they are quite tedious, esp when you have more than 1 blog). IT IS A BUG, so I don’t see why it shouldn’t be fixed for so long, rather than applying temporary solutions.

    mattvot
    Member

    @mattvot

    Here is what i do.

    I have the myphpmyadmin plugin.
    Use the myphpmyadmin or myphp to change post author fields to 1.

    Only a temp untill 2.6.2 comes out

    ndna
    Member

    @ndna

    Oh, do you know it for sure? Great!

    mickmel’s solution worked for me.

    Basically, created second admin account, then change original admin to a subscriber and back to admin. Now it works.

    Would love to see this bug fixed.

    Thank you mickmel, that did it. Weird bug.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Page/Post Author option “Admin” not available’ is closed to new replies.