WordPress.org

Support

Support » Plugins and Hacks » mqTranslate » [Resolved] page url language link error

[Resolved] page url language link error

Viewing 6 replies - 1 through 6 (of 6 total)
  • Same problem here.
    But using Pre-Path Mode (Default, puts /en/ in front of URL) solve the problem

    Plugin Author chsxf

    @chsxf

    This bug will be fixed with the plugin update for WordPress 3.8.
    It should be available by the end of the week.

    Hi,

    I want to create a menu at the top of the site with the options: English and Spanish.

    So when people click on English, they will go to the english version. The same with the spanish version.

    I tried writing the url in the menu link (www.website.com/en and http://www.website.com/es) but it doesn’t work.

    How can I give visitors the option to decide which language to see?

    Thanks

    Plugin Author chsxf

    @chsxf

    Hi,

    The correct URL structure depends on mqTranslate settings (Pre-path or Query string mode).

    However, you can use the mqTranslator widget to automatically build these links for you.
    Or, if you do not use widgets, you can use the qtrans_generateLanguageSelectCode() function in your template.

    I’m not using widgets.

    I set the URL to end with /en and /es. But when I use that link in the menu, it doesn’t work. Then, I tried using the en.website.com version, and with lang=?es. However, when I create the menu and put “Spanish” and “English”, the link only goes to the default language website.

    How do I use the qtrans_generateLanguageSelectCode() ?

    Thanks.

    Plugin Author chsxf

    @chsxf

    Just call qtrans_generateLanguageSelectCode() in your template PHP file.

    Take note than in Query mode, the right syntax is ?lang=es and NOT lang=?es

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] page url language link error’ is closed to new replies.
Skip to toolbar