Support » Plugin: Super Page Cache for Cloudflare » [NSFW] Page updates only showing when logged-in

  • Resolved fizzers

    (@fizzers)


    Hello,

    We’re having issues with Elementor Pro and caching – after publishing changes, they only show to logged in users (with the &swcfpc=1 parameter).

    We’ve tried purging the whole cache, using development mode in CF, disabling/reactivating Elementor and disabling/reactivating Super Page Cache, but no changes are showing e.g. new browser window in incognito.

    I’m not sure what else we can try to purge the old content from the site.

    • This topic was modified 2 years, 3 months ago by fizzers.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor iSaumya

    (@isaumya)

    Hi,
    Once you purge the cache it generally takes a few moment to purge the cache. Also can you enable the Log Verbisity to HIGH in the Plugin Settings > Others tab and then check the log after you publish or update an article?
    You should see all the steps the plugin is performing in the logs.

    Thread Starter fizzers

    (@fizzers)

    @isaumya I appreciate there’s a delay expected after publish; the issue we have is preventing any updates at all from being pushed live, it seems they’re stuck (but only if you’re logged out / don’t have the &swcfpc=1 parameter).

    I’ve tried looking for the Log Verbisity setting but unable to find it within Settings > Other?

    Plugin Contributor iSaumya

    (@isaumya)

    You basically need to go within this plugin settings then the Others tab and change the log verbosity: https://i.imgur.com/br1mDNo.png

    Then publish or update an article and wait for a few min and download the log file and check what actually happened.

    Thread Starter fizzers

    (@fizzers)

    Hello @isaumya,

    I had to enable log mode under General to get the log verbosity to appear.

    We’re still experiencing this issue – appreciate it might not be immediate but changes are taking days to appear – and purging CF Cache has no impact.

    I’ve reviewed the log files and nothing obvious is jumping out, though I’m not exactly sure what I’m looking for.

    Plugin Contributor iSaumya

    (@isaumya)

    So, when you are updating an existing post or adding a new article in the log are you see that those article pages are getting purged from Cloudflare cache?

    Thread Starter fizzers

    (@fizzers)

    I’m not sure what the exact problem is, except that it involves this plugin.

    Reviewing the logs again, I can see instances of "message": "Unable to purge, rate limit reached. Please wait and consider throttling your request speed". From what I can see, purging cache returns "success": true, however the cache doesn’t get purged.

    For example, we recently (days ago) updated the Trustpilot section on the main nav. The new version of the nav shows the Trustscore (4.8), whereas the old version shows the Trustscore (Excellent). In incognito, the old version is still shown. At the same time, as soon as you log in, the new version shows.

    edit: would it help if I shared the log file with you?

    • This reply was modified 2 years, 2 months ago by fizzers.
    Plugin Contributor iSaumya

    (@isaumya)

    Hi,
    The above message that you have shared means that you have reached your API call limit to Cloudflare API. You can make 1200 requests every 5 minutes to CF API.
    Link: https://support.cloudflare.com/hc/en-us/articles/200171456-How-many-API-calls-can-I-make-

    If you are making more API calls than that, then you need to contact Cloudflare Support asking them to increase your API call limit.

    Thread Starter fizzers

    (@fizzers)

    Hey,

    It’s a pretty low traffic site so this is a bit puzzling. Do you believe the API call limit is the reason why published content does not update properly? And if so, what Super Page Cache settings can affect this?

    Plugin Contributor iSaumya

    (@isaumya)

    It’s a pretty low traffic site so this is a bit puzzling.

    – Your traffic has nothing to do with API calls. If you have many pages in your site and you can purging cache for HTML pages then it will invoke multiple API calls. So, for large sites with many pages you will need higher API call limit.

    Do you believe the API call limit is the reason why published content does not update properly

    – Yes because CF does not process your request as you have reached the API call limit. Thats what the log is saying.

    And if so, what Super Page Cache settings can affect this?

    – If you have Cache only HTML pages options selected then when purging it will only purge the HTML pages instead of purging the whole cache of the website which leads to higher API calls if you have many pages on your website.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[NSFW] Page updates only showing when logged-in’ is closed to new replies.