Support » Fixing WordPress » Page templates missing in 4.9.1

  • Resolved Stuart Neilson

    (@stufreeze)


    The dropdown that allows me to select different page templates is missing, in the Page Attributes meta box I simply get Parent -> [droupdown] and then Order – [input field].

    I’ve seen this post https://core.trac.wordpress.org/ticket/42573 and I’ve made sure i have the latest version of WordPress (4.9.1) downloaded again from this site, I’ve tried various themes but I’m still getting the same issue.

    Does anyone know how to resolve this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator

    Does your theme actually have any alternate page templates? If there are none, the dropdown is not shown.

    http://prntscr.com/hnx9mm

    It is working – are you trying to change the template of your “posts” page? Because there it does now show http://prntscr.com/hnxaeh
    The post page is show based on the template files in the theme: https://developer.wordpress.org/themes/basics/template-hierarchy/

    If not, are you using any plugins? What version of PHP is your server running?

    Try installing Health Check plugin from WordPress to see if there is a conflict anywhere.

    Thread Starter Stuart Neilson

    (@stufreeze)

    @sterndata – Yeah our theme has multiple page templates we’ve been using for ages, we now just can’t change them or select new ones.

    @jaycbrf – No it’s pages not posts, we’ve already run health check and everything is fine.

    All plugins have been disabled across the multisite network so it’s not a conflict with anything else. The set up is the same on both our local environments running WampServer and our live site:
    Apache Version: 2.4.27
    PHP Version: 7.0.23
    MySQL Version: 5.7.19

    It’s really odd so just wondered if anyone else was seeing the same thing?

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator

    In 4.9, you could get around the issue (fixed in 4.9.1, one thought) by enabling wp_debug. What happens if you try that? If it fixes anything, then a trac ticket is probably the best course.

    Hi, I got the same problem after upgrading wordpress to 4.9.2. The template selector disappeared from the page editor. Does anyone know how to get it back?

    UPDATE – SOLVED
    In the style.css file of the active WP theme the values of ‘Theme Name’ and ‘Template’ were the same. Removal of row with ‘Template’ solved problem.

    • This reply was modified 4 years, 10 months ago by mbr55aa.

    Thanks, mbr55aa! saved my life!

    @mbr55aa Could you please explain in more detail in how you’ve achieved this fix? I tried doing what you said but I’m kinda confused

    @rafaelcmrj @mbr55aa
    Apology for basic, just started with WP.
    Having WordPress 4.9.5 running Twenty Sixteen theme.

    i am trying to create custom page for display data using php file. However, the custom template page route is not happening as new page doesnt show template section in Page attribute. Tried removing display: none; in style.css but still the same issue.

    [hidden],
    template {
    display: none;
    }

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator

    @neno92, if you need support then per the forum welcome please create your own new forum post. Thanks.

    @banks1502 try inserting this inside the <main> <?php get_template(); ?> </main>

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Page templates missing in 4.9.1’ is closed to new replies.