Support » Themes and Templates » Page Templates in WordPress 2.5?!

  • Hello.

    I’ve just installed WordPress 2.5 as part of a client development. Everything is going find except I can’t find where to select ‘Page Templates’?!

    Looking at other posts I know is suppose to appear between Page Parent and Page Order at the bottom of the Page editing page, but it just ain’t there?

    I’ve created the page and inserted the necessary Tags…

    <?php
    /*
    Template Name: Clients
    */
    ?>

    But still no joy.

    Anyone got any ideas?

Viewing 15 replies - 16 through 30 (of 56 total)
  • OK, so I have ruled out caching issues in FireFox and IE by going on different computers, even non-networked computers and I still get the same thing. I am only running one version as I have not upgraded yet on other installations.

    Is this a plugin or settings issue?

    I have Akismet, Search Everything, and wpSEO as plugins on my installation. Disabling these plugins has no affect.

    This leads me to believe this is a setting issue or something drasticly wrong with an upgrade.

    Does this happen on New installs or just upgrades?

    silly

    but: use default theme — surf a while with default theme,
    after this change to your preferred theme

    maybe WP *insideCache* can’t remember …

    WP 2.3.3 any developer Version of WP 2.5 and I have the dropdown for individual page templates

    regards

    Just to add to this, my Page Template box comes and goes as it pleases. I made two template and was able to change between them all yesterday. Then today they disappeared. Five minutes ago they came back again!

    I’m using WP 2.5, Firefox and my install is on my PC/localhost.

    Monika, did you change anything? Any settings or did you upload another file of some sort? Sounds too much like voodoo. Tried it and no luck. Added another user and the “Page Author” shows up.

    I am now thinking of restoring my previous version of WP.

    webwisedesign: I did literally nothing more than what you’re saying. Make a php file, stuck that header into it, uploaded to my theme directory and that was it. I did nothing else of any kind.

    Try switching to the default theme and back. I dunno. What you and others are telling me doesn’t make any sense. I believe you, but I don’t see how it’s possible. The code works very simply, there’s really no room I can find for it to not work.

    Possibility: Maybe you did not upload all the wp-admin and wp-includes files? Did you overwrite? Perhaps you have some old 2.3 files lying around somewhere that are interfering? I can’t think of *any* reason that a normal 2.5 installation would do this, but if you have some kind of weird hybrid, then anything is possible, I guess.

    Yes Otto, I thought of that too, but it appears (after checking my 2.3.3 backup and the live 2.5) that the only things that were unchanged are my htaccess file, wp-config file, and the plugins Search Everything and wpSEO. The Akismet plugin was updated after the update to 2.5. I did try disabling all the plugins, but still no luck. I don’t consider myself a Newby at WP (having developed my own themes and have used WP as a CMS) but I now feel like one. I am using this install as a CMS and therefor the page template issue is very important. This upgrade is my test and I am not comfortable yet with upgrading the rest of our sites and blogs. Sorry, I am probably venting as I too can see no reason for this.

    my switch-example is no *vodoo* /laughing,

    but it is a simple method to clear browsercache because sometimes browsercache is harder to clear than to code a bugfree WP 😉

    😉

    Eric Amundson

    (@sewmyheadon)

    Volunteer Moderator

    I noticed the same issue and like Monika had a similar fix. Not sure it always works yet, but here’s what I did:

    After upgrading a site from 2.3.3, it was using the same theme I’d used in the past. When I tried to write a page based on a template, I didn’t see the dropdown.

    So, I jumped over to Design and selected my desired theme again.

    Then, switching back to the page I was writing, the Page Templates dropdown appears where it should be.

    Hope this helps.

    I had the same problem (which is how i found this post). No matter how many times I refreshed and checked my code I couldn’t find a solution. But then I changed my template to Default template and then back to my custom template, went to Manage -> Pages, chose my page, and the page template box now displays.

    I don’t know if this helps. A bit redundant, but I could not get the Page Template dropdown box either. I tried REFRESH but it did not help me.

    But what appears to have worked is when I cleared all PRIVATE DATE informaton in firefox (Tools/Clear Private Data/Browsing History, Saved Form Search History, Cache and AUTHENTICATED Sessions) BEFORE clicking on REFRESH on the WordPress/Write/Page

    This is probably obvious to all of you – but be sure the template name in your code matches the name of the new php file. This had happened to me “way back”, I had used – in the template name, but named the file with an underscore _(a note in case a newy like me visits this blog!)

    Open: page.php
    Rename file for example: photography.php
    Insert code at the top

    <?php
    /*
    Template Name: photography
    */
    ?>

    Fortunately, I’m one of the blessed right now who can see the dropdown box!

    Kathi

    switch to default theme and then back to my theme helped.

    switching to default theme and back worked for me as well.

    Sorry Ladies and Gentlemen, I am heading back to 2.3.3. If this were a caching issue it would have been resolved last week as I have tried this on several computers including one not on our network (not even through the same ISP) and have repeatedly emptied the cache from IE and FF in an attempt to get this to work. Tried every option of themes (Switching from default to any of our three standard and tested themes too many times to count), then went back to 2.3.3 (where templates worked) and reinstalled 2.5 – all to no avail. I may try again when 2.5.1 comes out. 🙁

    Thanks to all but this issue has not, as of yet, been resolved.

    I tried switching to default and back and it worked for me.

    Maybe it’s not a caching issue but an internal field that WP sets when switching themes… something like that…

    Figured out a “cure”. Placed my developed theme in the default theme directory (is this illegal?). Everything works now!

Viewing 15 replies - 16 through 30 (of 56 total)
  • The topic ‘Page Templates in WordPress 2.5?!’ is closed to new replies.