WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Page Template Problems with 2.6

[Resolved] Page Template Problems with 2.6

  • TheSooFoo
    Member

    @thesoofoo

    When I had 2.5 I had several page templates I made by pasting a line of code into the top of a page:

    <?php
    /*
    Template Name: Map Page
    */
    ?>

    So when I went to write a page, I was able to choose the “Map Page” template from a drop down menu.

    After I upgraded to 2.6 I lost that drop box on the write page.

    Any Ideas?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Do you still have the Page Templates there?

    WordPress only shows the drop down box when it finds actual Page Templates in your theme directory that you can use.

    TheSooFoo
    Member

    @thesoofoo

    Yes, they are all still there. All previous pages made with custom page templates have been left intact.

    Maybe try deleting (back it up, first) then re-uploading that file?

    TheSooFoo
    Member

    @thesoofoo

    I just tried, that, thinking that had to be the fix. Nope. I think I am going to have to start disabling plugins and see what happens.

    Trying giving it a different name, both the template and file name. Since your other templates are still there and working, maybe WO has a problem with Map Page and/or map.php. But yeah, post back with how disabling plugins goes. I’m curious.

    I have the same problem with a virgin install of 2.6, I’m trying to use a different page template for certain pages and am not getting the drop-down box for selection.
    The additional template (onecol.php) carries the following code:
    \
    <?php
    /*
    Template Name: onecol
    */
    ?>
    \
    I’ve done this a ton of times on 2.5.
    Have tried disabling all of the plug-ins and it’s made no difference, I’ve also tried numerous different file and template page names, but to no avail.

    This is for a client so any assistance would be appreciated!

    Thanks guys

    TheSooFoo
    Member

    @thesoofoo

    Sweet, issue resolved!

    I made a template under the Default theme, then switched to that theme, and there was a drop down for templates, which is what I was lacking before.

    So I switched back to my custom theme, and there it was, the drop down box for page templates.

    Thanks for your help!

    TheSooFoo
    Member

    @thesoofoo

    So I bet that if you just switch to another theme, and then go back to your normal theme, the issue can be fixed that way.

    Bizarre but true – I’ve just changed to another theme then changed straight back and low-and-behold there it is.

    Nice work TheSooFoo!

    I was having this same problem, and TheSooFoo’s suggestion worked!

    I got the template drop down back this way a few minutes ago – but it is not listing my templates. Just default, archives and links.

    Celso Bessa
    Participant

    @celsobessa

    Totally Weiiiiiiiiiiiiiiiirdo. Got same problem into my company’s intranet site.

    txblond
    Member

    @txblond

    Changed to default…had the drop down.
    Changed back to my theme…no drop down.
    Any other way to work around this? Cause it massively sucks!

    matthijs
    Participant

    @matthijs

    I have the same problem here. disappearing of the box with the template chooser. After switching to another theme and immediately switching back problem solved.

    This must be a bug and be set as a ticket.

    matthijs
    Participant

    @matthijs

    I haved submitted a ticket in Trac for this.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Page Template Problems with 2.6’ is closed to new replies.