WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Page template problem

[Resolved] Page template problem

  • Hi,

    My wordpress is not using the page template for the pages, and it is just displaying the index page whenever I try to access any page. To troubleshoot the issue, I tried to use a custom template also for one of the page(My url was http://localhost/wordpress/contact and the custom template I have added was page-contact.php). However even this was not working. The theme I am using is twenty eleven.

    thank you for the help.

    thanks
    -Albin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The problem exist for any theme I am using.

    The only plugin I am using is the Custom Post type UI. If I deactivate the plugin everything is working fine.

    Have you tried updating your permalink structure?

    Yes I did update my permalink structure and it did not work.

    Now I use a different plugin for creating the custom post type and everything is working fine :-).

    This looks like a bug to me in Custom Post type UI plugin. The steps to replicate the issue. Install a fresh copy of wordpress 3.2.1 and install the plugin. Create a custom post type and add taxonomy to it. Now go to permalink to refresh the rules. Create a new page and try to access it. Instead of the page, the index page will be shown.

    Thank you for the help.

    Same issue here I think. It’s a bit maddening! Custom post type works, but other pages show index page.

    albinjoseph

    @albinjoseph

    I got the problem finally. Its not a bug in the plugin. One of my taxonomy had a wordpress reserved word as the name and it created the issue.

    noelhefele

    @noelhefele

    It isn’t a bug for the plugin – for me I got it to work with the permalinks.

    I had to add a real word to the permalinks — i.e. (artworks/%year%/%monthnum%/%gallery%)

    I then used the Custom Post Type UI (enhanced) plugin, which has a rewrite front option.

    Seemed to have solved the issue.

    Making sure to not overlap custom names also seems very important…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Page template problem’ is closed to new replies.