Support » How-To and Troubleshooting » Page Template Missing in 2.8

Page Template Missing in 2.8

  • I’m trying to create a custom page template. I followed all the instructions and still not getting any templates to show up in the drop down menu.

    Here are some of the bug fixes I’ve tried so far:
    1. I have switched the theme to default and back to mine
    2. Deactivated all plug-ins
    3. Reinstalled newest version of WordPress
    4. Uploaded three different page templates, two that I created and one that works in another theme.

    I don’t know much about the backend, but it’s like the server(database?) isn’t recognizing any new templates. Any suggestions?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m using arthemia premium theme and my site is at http://www.thesnowjunkies.com if that helps.

    Thanks for the response, but this I’m talking about the page template that shows up when I’m writing pages. Not sure what the drop down links are for.

    I’m having a similar problem.

    There is a valid archives.php template in my theme’s files but there is no “Page Template” box/dropdown/anything in the sidebar of the Edit Page section in WordPress 2.8… can anyone help?

    I’m using Autumn Forest 1.0 theme.




    I am having the same issue ever since I upgraded from wordpress 2.5 to 2.7 and now 2.8.4 — when I go to write a page I don’t have a dropdown to select the page template – -this worked before I upgraded to 2.7 … I see no option for selecting any of my valid template files …

    Same problem here in Version 2.8.4. I checked MichalH’s link and I do have a template file with that code at the top. The custom template shows up in the editor as a page template, but when I add or edit a page, I have no choice of template. I also tried setting the blog back to the default theme then to my preferred theme, as suggested, but it didn’t help. Isn’t there anything else we can do?

    Is this a bug in 2.8?

    I have all the right template code as well and was working in 2.5 and the local version of 2.5 works just fine–seems no one is able to answer this issue – -real bummer because it is a major issue for me!!

    anyone? got the same problem with stocks starkers theme… need help! please…

    oh – i found something!!!! and it´s working:

    line 288 in my file though – but it worked!!!

    Rejoyed too soon!

    the drop-down-menu is now showing – but only the default theme. no more choices.. ???
    please need your help!

    solved my problem.
    i simply didn´t name my theme in the css-file properly.
    so wp had some difficulties it seems…

    Theme Name: XY

    now it works…. so easy….

    Another thing you might try –

    I changed the name of my currently activated theme in the style.css and uploaded it – and had this exact problem – no way to change the Page Template on a Page – the dropdown was either empty or just had Default Template in it.

    Solved by going back to Appearance–>Themes and RE-ACTIVATING the theme after changing the Template Name – even by just ONE character. (current theme at the top had . – . but no name/description anymore)

    Also – from the MU side of it – you’ll want to avoid certain characters in your theme names – the “-” dash was giving me fits on a MU install – can’t remember exactly what was wrong because it took me forever to find the solution, but hope that also helps someone out in case you’re stuck.

    i recently did this too and it was due to me removing the index.php from my theme folder. i had done this as i was using all custom templates and forgot that index.php must be in there!

    Hey I am having the same problem. I haven’t been able to find a fix for myself, but what worked for some others is setting their permissions to 755.
    How to do this?
    If you are using Dreamweaver:
    Go to Files (not File)
    Click the fly out menu
    Go to Site
    Set Permissions
    Type 755
    Good Luck to all of us!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Page Template Missing in 2.8’ is closed to new replies.