WordPress.org

Support

Support » How-To and Troubleshooting » Page takes long to load

Page takes long to load

  • Ajay
    Participant

    @ajay

    My index page at http://www.ajaydsouza.com takes way too long to load.

    4549 queries. 27.675 seconds.

    is an example of this in my footer.

    As a result the server of my hosts slows down.

    Inner pages don’t seem to have this problem.

    Can anyone please help me solve this problem ASAP?

Viewing 12 replies - 1 through 12 (of 12 total)
  • James Huff
    Support Team Rep.

    @macmanx

    Do you have the same load time when using no plugins and the Default (unmodified) theme? If you do, then this is a server issue. If you don’t, troubleshoot the problem down from there to find out if it’s your theme or one of your plugins.

    Ajay
    Participant

    @ajay

    I am on the default theme as of now, and that hasn’t made a difference.

    Does your WP also take these many amount of queries?

    My host has found that after my site is suspended, the server load goes down.

    Also I can’t figure out why only on the main page and not the inner pages.

    Should I try disabling all my plugins? Any shortcut way to do so without doing 1 by 1?

    James Huff
    Support Team Rep.

    @macmanx

    Yes, try disabling all plugins. You’ll have to do it one by one. My blog uses the Wuhan theme and five plugins, and it executes 17 queries in 0.15 seconds.

    You should disable them all at once and then re-enabler them one by one. That way you will know straight off if it is the plugin’s fault.

    Cron

    James Huff
    Support Team Rep.

    @macmanx

    I think he meant if there was a short cut to having to click “deactivate” for each plugin, but if I misunderstood, I apologize. You should definitely disable all plugins first, then re-activate one-by-one.

    Ajay
    Participant

    @ajay

    I figured out the problem.

    It was with the Kg Archives plugin that was slowing down the page.

    I brought down load time from 20+seconds to under 1 second.
    Also reduced the number of quries to 45.

    wow! that was a lot of queries -4549

    Ajay
    Participant

    @ajay

    Yup, I am kinda stunned. Though I can’t understand how KG Archives caused that on my site.

    Anyone else running it here?

    James Huff
    Support Team Rep.

    @macmanx

    Now that you mention it, I remember hearing of similar problems with KG Archives.

    Denis de Bernardy
    Member

    @denis-de-bernardy

    Sheesh… This is even worse than Zen Cart. 🙂

    Ajay
    Participant

    @ajay

    I won’t condemn it just yet. I posted on the authors page to bring it to his notice.

    Ajay
    Participant

    @ajay

    The author solved the problem.

    http://katesgasis.com/2005/05/29/kg-archives-v13/

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Page takes long to load’ is closed to new replies.