Support » Plugin: Elementor Page Builder » Page suddenly broke and showing plaintext HTML

  • I didn’t change anything, but the page suddenly broke and is showing the HTML directly on the page. There are some console errors, but they don’t look related. Has anyone had this happen with Elementor before?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • An update on this. I tried to restore from a previous revision of the page (because apparently the older versions looked fine, and I have no idea what changed without me saving anything), but when I try to restore it loads all the way and never quite updates. Weird things happening with my Elementor.

    I’m not sure this will solve your problem but it sounds like your CSS is not loading.

    Others are having issues where the permissions of the CSS files on the server are wrong preventing them from loading.

    https://wordpress.org/support/topic/missing-stysles/

    and here

    https://wordpress.org/support/topic/css-permission-0600/

    And how I can solve the Problem?

    Plugin Support davidr90

    (@davidr90)

    We are currently checking into this issue.

    Can you all please confirm that you are using LiteSpeed servers?

    You can check it by logging into your WP dashboard > Elementor > System Info > Server Environment > Software field.

    Thanks

    Hi david, I’m not using LiteSpeed. I’m using Apache. Is this something I need to change for Elementor to work properly?

    Plugin Support davidr90

    (@davidr90)

    Can you please make sure that your read/write permissions of the uploads folder are not 0600?

    Please also send me your system info, so we could check this further.

    They are not. All the folders are the default of 755 (and the files the default of 644). One thing that’s weird is that within uploads > elementor > css the folder is empty. Not sure if that is supposed to be the case.

    Not sure if related but mines showing the content with all as text and I also could not restore to an older version that looked fine.

    https://wordpress.org/support/topic/all-elementor-blocks-now-combined-into-1-text-editor-block/

    • This reply was modified 6 months, 3 weeks ago by erincheung.

    Another update with more information if it’s helpful. I found another page that I was not using with an old test design I made in Elementor. That page seemed to still be functioning normally: https://biketoeverything.com/home/

    However, when I tried to “Edit with Elementor” it showed up with this error about “The Content Area Was Not Found in Your Page”. I found this help page https://docs.elementor.com/article/56-content-area-not-found?utm_source=editor-panel&utm_medium=wp-dash&utm_campaign=learn

    I’ve deactivated my Essential Add Ons just to make sure that wasn’t it, no changes. It seems now that I’ve lost some of the data for my Elementor pages or something like that and the page above is just cached somewhere. Weird things.

    Plugin Support davidr90

    (@davidr90)

    Hi,

    Have you gone over all the information in our ‘content area not found’ guide?
    If so, and your still see this error message,
    please let me know if this happens on a specific page, please send it here.

    Have you tried editing a new page? do you still see any issue?

    I fixed this problem in the end by going into the broken page and going back to a revision that was working. Then I clicked the arrow (save options) next to “Update” and clicked “Save as Template.” Once I saved it as a template, I was able to create a new elementor page and load that template and everything was working.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.