Support » Plugin: Cache Enabler - WordPress Cache » Page specific cache not purged while using Gutenberg

  • Resolved wemnael

    (@wemnael)


    I’ve seen there is another topic with this title. This is a very serious issue. My site was loosing traffic because every time I updated a page using the new editor, it never updated on user-side. And I din’t notice until now!! What can I do?

    Victor

Viewing 2 replies - 1 through 2 (of 2 total)
  • There are a couple options currently available to work around this issue. The first would be using the Classic Editor instead of Gutenberg.

    If you’d like to continue using Gutenberg an alternative option would be using the save_post action with the Cache Enabler clear post cache hook to clear the individual post cache when updated. This can be achieved through a custom function added to your functions.php file located in your theme’s folder, for example:

    function clear_post_cache_on_save_post($post_id) {
        do_action('ce_clear_post_cache', $post_id);
    }
    add_action('save_post', 'clear_post_cache_on_save_post');

    Awesome! Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.