WordPress.org

Forums

[resolved] Page Slugs and Permalinks Questions (5 posts)

  1. fmueller
    Member
    Posted 6 years ago #

    I am setting up a new web site using WordPress as CMS at http://www.ohiocichlid.com. That links takes me to an error message 'page not found'. I can navigate from there to 'Ohio Cichlid Association (http://www.ohiocichlid.com/?page_id=3, top item in navbar). I want to make that my main page (index page/home). How do I do that? On my old site (www.fmueller.com) I believe I simple made the page slug of the main page 'home', but I can't see how to define the page slug in the latest version of WordPress.

    I am also having trouble with using pretty permalinks on http://www.ohiocichlid.com. In http://www.fmueller.com I chose under Options/Permalinks/Custom structure: /http:/example.com/category/post-name/

    I tried the same for http://www.ohiocichlid.com under Settings/Permalinks, but if I do so none of the pages are found if I click on the navbar. What am I doing wrong? (I am pretty sure the server has Apache's mod_rewrite module, but I have emailed the web host to double check).

    Finally, unlike http://www.fmueller.com, http://www.ohiocichlid.com doesn't seem to have an .htaccess file. What's up with that?

    Many thanks in advance!

    Frank

  2. fmueller
    Member
    Posted 6 years ago #

    Sorry for the hasty posting. I copied the .htaccess file from my old site http://www.fmueller.com to the new site, http://www.ohiocichlid.com, and that took care of the permalink issue. I am still fighting with the page slug issue.

  3. geoff67
    Member
    Posted 6 years ago #

    I'm assuming you don't want a blog for the homepage, and just the text on http://www.ohiocichlid.com/home/ ?
    I'd create a new page template and rename that as your index.php. Also, your permalinks seem to be working now.

  4. fmueller
    Member
    Posted 6 years ago #

    Yes, the permalink issue has worked itself out!

    I want the page at http://www.ohiocichlid.com/home/ to appear when I type http://www.ohiocichlid.com into the browser. How can I make that happen?

    Many thanks!

    Frank

  5. fmueller
    Member
    Posted 6 years ago #

    Never mind, I found it! You can set a front page under settings/reading!

    Many thanks!

    Frank

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.