WordPress.org

Forums

Page Slug Not Working (3 posts)

  1. mmorowitz
    Member
    Posted 6 years ago #

    I've created a new page and set a slug attribute for it and all I get is a 404 from my webserver when trying to access mydomain.com/myslug

    I'm not even sure how to troubleshoot this. Any specifics on how to make the "slug" attribute of a page work?

    Thank you.

  2. stvwlf
    Member
    Posted 6 years ago #

    1) Is this happening on ALL slugs or just that one? (Or do you only have one page on a new install)?

    2) Try resetting your permalinks. Admin / Settings / Permalinks
    reset to default
    see if it works - if yes, reset back to what they were prior to reset to default

    make sure you see no messages on the permalinks page about "WordPress couldn't update your .htaccess file". If you do see messages like that you have to do what the messages are telling you to do

  3. mmorowitz
    Member
    Posted 6 years ago #

    It happens to all slugs.

    So, my permalinks were set to default. So, I changed them to "Day and Name" and the slug worked. When I changed back to default, it didn't work.

    Since the default (p=xxxx) still works when updating to "day and name", I'll just leave it at that going forward now that I have slugs working.

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags