Support » Plugin: Custom Product Tabs for WooCommerce » Page skips during scroll after new tab selected

  • Resolved michaeljacoby

    (@michaeljacoby)


    I’m not sure if this has been asked, but in my theme (Sober theme), when I hit a new product tab and then try to scroll down right away the scroll “sticks” or jumps a bit. When I disable custom tabs the problem goes away. Has anyone encountered this or has a solution?

    Thanks in advance for any help or advice.
    -Mike

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hi Mike,

    I see what you mean. I am not sure what’s going on and I haven’t seen this before. I have seen similar things in web development and they’re usually caused by a CSS/JavaScript animation. There is some additional mark-up around the tabs (more than the default WooCommerce markup) like the line animation. I think these additions are coming from your theme. Do you have any way of contacting your theme developer about this?

    Let me know.

    All the best,
    Kevin.

    Thread Starter michaeljacoby

    (@michaeljacoby)

    Hi Kevin, thanks for the reply!

    I have contacted the theme people and I’ll see what they say. Thanks so much for the hints, I take a deeper look at the code.

    -Mike

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hey Mike,

    Sounds good.

    One way to see if the issue is coming from our plugin or your theme’s tab layout would be to add a Description (and maybe the other default tabs, like a reviews tab or additional information tab) to a new product or a product that has no custom tabs. Fill these with some content and check if the scroll stick/jump is still occurring.

    Cheers,
    Kevin.

    Thread Starter michaeljacoby

    (@michaeljacoby)

    Just wanted to close the loop on this. It ended up being a conflict with the smooth scroll plugin I was using. I switched to another smooth scroll plugin that allowed me to exclude specific tabs. Once I excluded the custom product tabs everything went back to normal. Thanks for the help!

    -Mike

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hey Mike.

    Agh that makes sense! Thanks for letting us know. Would you mind pasting the URL to the Smooth Scroll plugin so any future users will know of this issue?

    Thanks again for getting back to us.

    Cheers,
    Kevin.

    Edit: I was unclear above. Would you mind posting the URL to both of the Smooth Scroll plugins (the one that created issues and the one that worked for you)?

    • This reply was modified 4 years, 3 months ago by yikesitskevin.
    Thread Starter michaeljacoby

    (@michaeljacoby)

    Here are the plugin details…

    Originally I used “Surbma – Smooth Scroll” (https://wordpress.org/plugins/surbma-smooth-scroll/) but that plugin is focused on being super lightweight so it didn’t have any options.

    Switched to “Easy Smooth Scroll Links” (https://wordpress.org/plugins/easy-smooth-scroll-links/) and under the plugin settings section you can enter in the anchor links you want to exclude.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Page skips during scroll after new tab selected’ is closed to new replies.