Support » Plugin: Yoast SEO » page-sitemap.xml#

  • In my WordPress SE0 plugin sitemap.xml file I find a page created called “#” or otherwise links to page-sitemap.xml#.

    This page does not exist in the WordPress dashboard.
    The site is located at The sitemap is

    What can I do to fix this?

    Also you will see many pages in the page-sitemap.xml that were generated by WooCommerce or the simplicity theme from that are /features/ or /shortcodes/ pages etc. Should I delete these pages? I have blocked them in the robots.txt file but since they are still in the sitemap file Webmaster Tools is freaking out and states there are “severe health issues”

    What is the cause of the problem? WordPress SEO? WooCommerce? Simplicity Theme? Or all of the above?

    Lastly, I would like some tips on what to included in the sitemap_index.xml file. as WooCommerce adds many different options with categories and tags etc…and I am uncertain what to include in the sitemap.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Me too! Searched files, folders, and database tables, not finding the sitemap file that I might edit. There is a # (only) on line two of my sitemap that Google does not like, worried I am de-ranked for it with new Google policies? Hoped WordPress SEO updates would fix it but no fix. I could edit each generation (not so often). If I delete/reinstall the plugin I’ll have to rethink/reset a lot of parameters again, much else to do already…
    Thank you! Anybody? cannot be found for editing. Unselected WP-SEO sitemap option. Installed Google Sitemap Plugin. It generated TWO lines with # only (instead of only one with WP-SEO), so there may be something not right elsewhere, will figure that out someday.

    Nonetheless, with GSP I could find and remove the faulty entries. I can deactivate the Google Sitemap Plugin until I want a new sitemap, so no blind surprises.

    I experimented back and forth with these two plugins. The faulty entries reoccur in the two file names. Thus activating GSP as needed and then editing the file is my workaround for now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘page-sitemap.xml#’ is closed to new replies.