WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » Page SEO section not saving

Page SEO section not saving

  • WordPress version: 3.6-alpha-23230
    WordPress SEO version: Version 1.3.4.1

    I did this:
    I edited a the SEO section below the page content editor. Shown here. http://cl.ly/LsWW and then updated the page. No matter what I enter in any of the fields whenever I update the page the content in the SEO section is lost.

    I expected the plugin to do this: I expected to see the content I added appear in those fields however it does not seem to be saving as the preview never reflects the changes I would have like to appear.

    Instead it did this:

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 15 replies - 1 through 15 (of 22 total)
  • I am having the exact same issue. None of my metadata for my pages are saving.

    It could be a plugin conflict, but I’m afraid to test on my live website.

    Help!!

    Any news here? Same problem. Have hardly any plugins installed and NO other SEO plugins at all installed.

    Same problem here. For posts it works though, not for pages.

    Having this same problem on my homepage.

    I am also having the same issue. Any updates from anyone?

    I am also having the same issue and it’s murder. I’m trying to update the site tagline to be included in the meta description of the homepage of the site and because of this error my descriptors don’t match – damaging the SEO.

    I started a thread about this while back but no solution or response from Yoast yet.

    http://wordpress.org/support/topic/cant-change-titles-and-descriptions

    In my case, it is not a plugin conflict as I have tried disabling all plugins but WordPress SEO and it did not fix the problem.

    What does work is switching to a default WordPress theme then switching back to the site’s regular theme. This only works temporarily and the problem comes back after a few days.

    Problem exists in all browsers.

    I don’t see any errors in Chrome console, and WordPress debug mode offers no clues that I see.

    Please see my answer in http://wordpress.org/support/topic/cant-change-titles-and-descriptions?replies=9#post-3843938

    I need feedback to know whether this is an OK fix or not :]

    a.

    Having this issue to!

    I have had the same problem as everyone else, the SEO Titles and Description worked on every page and every post except the homepage, when it simply wouldn’t save my new titles and description.

    The solution recommended by axelay above worked for me. I don’t know if it effects any other part of the plugin but it solved the issue I was having. It’s an excellent Plugin so hopefully they can solve this issue permanently in the next release.

    Problem still not solved. Posts are saved, pages not. Axelay’s hack is not working in recent versions.

    WP 3.5.1 & WordPress SEO 1.4.12

    Net Admin

    @red-bud-industries

    I have figured out a work around for the issue of the home page meta description not changing.

    Go to import/export and export your settings. It will save a file named settings.zip. Inside is a settings.ini where you can make the necessary changes (mine was after “metadesc-home =”). Save that settings.ini file and recompress to settings.zip Import the updated settings.zip file, and my home page meta description is now changed.

    Hi all,

    I’d like to look into this issue, but I can not reproduce the problem on WP 3.5.2, WP SEO 1.4.13 with theme: twentytwelve.

    The more info I get, the better chance there is that I can solve it.

    So for those willing to help get this fixed, please give me as much information as you can for the following questions:

    1. What theme are you using when the problem occurs ?
    2. Does it still occur using one of the WP default themes ? (some say it does, some say it doesn’t)
    3. Does it still occur if all other plugins are deactivated ?
    4. What – if any – PHP error messages do you see in your error log ? or on the screen/in the page source if you have WP_DEBUG enabled ?
    5. What – if any – Javascript errors do you see in the JS console ?

    Please only post errors which relate to WP SEO!

    If you are currently not logging PHP errors, have a look at this code which you can add to your wp-config.php file.
    It will log any and all php errors to a file, independently of whether you have WP_DEBUG set to true. That way you can keep track of PHP issues on a live website.

    I’d be very interested to hear if any errors relating to this issue show up in the log.

    Be aware: logging errors will generally scare the living daylights out of most people as they suddenly start realising how many plugins are throwing errors….

    Look forward to hearing more.

    Smile,
    Juliette

    Hi Juliette,

    so I turned off and on all the plugins till I found out the bug is caused by the WPML Multilingual CMS 2.9, no other plugin or theme is related (WP 3.5.2, WP SEO 1.4.13).

    I found no php errors, only minor css related warnings, like unknown property zoom and -moz-border-radius in file: metabox-tabs.css

    Anyone else solved this by deactivating WPML? Should I report this to the plugin authors?

    @all: more input and/or confirmation that this is a WPML/WP SEO combination issue is welcome!

    @hoppylorinc I would definitely advise you to report this to the plugin authors.

    As WPML is a premium/paid plugin which I have not bought, I can not test this to figure out where the problem lies.

    One more thing: when you say, you have found no php errors, is that just with WP_DEBUG on or with error_logging on ? error_logging can show more errors than WP_DEBUG.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Page SEO section not saving’ is closed to new replies.
Skip to toolbar