Support » Theme: Storytime » Page Right Sidebar doesn’t accept widgets

  • Resolved Edna Houston

    (@ediehouston)


    When selecting “Page Right Sidebar” as template, the right sidebar is shown as you view the page, but when going into “customerizer” any widgets added to that template do not show up. You have to add widgets to “blog-sidebar” then set visibility to show on page “about”. I haven’t tested the “page left sidebar” yet to see if the same problem exists.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andre

    (@andre-jutras)

    Hi Edna,

    I’m not sure I completely follow…you are saying you add a widget to the page right sidebar in the customizer when that page is in your preview window, but the widget does not show up there? Does it show on the front-end of your website?

    I just tried it on my local test site and was able to view the widget as I added a couple to the page and seen them in the preview.

    What are you using to show widgets on select pages?

    I think I have it worked out now. Apparently, there really isn’t any “right-page-sidebar”. When you select the template “right-page-sidebar” is is just using a narrow page template that pulls “blog-sidebar” and you have to use visibility setting to determine which pages your widgets show on.

    I was confused because when you are looking at a page using “page-right-template” and click “customize” –> widgets –> right-sidebar and try to add widgets to the right-sidebar, they never show up anyplace. I’ve got it now. Thanks.

    Andre

    (@andre-jutras)

    Actually, how it works is that there are three templates:

    1. Full width (no left or right sidebar). This is the default template.
    2. Left Column template has a left column.
    3. Right column template has a right column.

    The left and the right column templates have a “page” sidebar for either one. So if you put a widget in the “Page Left” sidebar position, this will only show on the left column template (and any pages using that template). Likewise, if you put a widget in the “Page Right” sidebar position, these will only show on pages that use the Right Column template.

    The blog pages (the home, single, etc) are coded to use the “Blog Sidebar”.

    But my concern is that if you are viewing a page using, for example, the Right Column sidebar and you then publish a widget to the Page Right sidebar, it should show up in the preview window, as well, the front-end of your site for that page. I just tested this again and it worked for me. The same for the Left Sidebar.

    Basically, I have separated the sidebars, one for all the blog pages, then for actual pages, I have a left and a right sidebar (two separate sidebars).

    Ok. That is not how it behaves for me. If I am viewing a page that uses “right-page-sidebar” and I publish a widget to “pagep-right-sidebar”, in the customizer in the left column (where you add and organize the widgets) it shows the widget. On the right side (the preview side) it does NOT show the widget. And the widget doesn’t show on any page that uses the “page-right-sidebar” (template (http://domain.com/about, http://domain.com/links, etc)

    I can make the widget show on these pages by adding it to the “blog-sidebar’ and setting the visibility to “show-if-page-is-about”, etc.

    I should clarify that I am using a child theme although the only files the child theme folder contains is style.css and functions.php. I have not created any specialty pages
    yet. The only thing the style sheet does is the standard import of parent styles and create a highlight box with blue background. The only function I have created is to hide posts in the category “uncatagorized” from the blog page. So the child theme is very “vanilla”
    I’m now wondering if this is a conflict with a plugin so I’m going to do some testing on another site I have. I will use the theme as is and disable all plugins and see what happens.

    Ok. I have loaded up everything in my test side and am running it from Storytime itself and it behaves just as you say it should. I obviously have some kind of conflict so now it’s on to the “bug-hunt” to find just where that problem happens to be. Consider this solved in that it is MY problem, not yours 🙂 Thanks so much for your help.

    • This reply was modified 4 months, 1 week ago by  Edna Houston.
    • This reply was modified 4 months, 1 week ago by  Edna Houston.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.