Support » Plugins and Hacks » [Resolved] Page Refreshes / Request URI Too Large

[Resolved] Page Refreshes / Request URI Too Large

  • Plugin Author photocrati


    This thread is referring to the error of the screen to add images to a gallery appearing but auto-refreshes repeatedly until you see the following error:

    Request-URI Too Large
    The requested URL’s length exceeds the capacity limit for this server.

    If you are experiencing this error, please detail the below needed information + temp. login information in a Bug Report to us here. Thanks!

    – WordPress up to date?
    – NextGEN up to date?

    (please confirm the following, with your server host tech) :
    – MySQL up to date (5.2.4)?
    – PHP up to date (5.0)?
    – The mod_rewrite Apache module activated?
    – PHP Safe Mode OFF?

    and if you’re willing to share:
    – Who are you hosted with?
    – What theme are you running?
    – Which plugins do you have installed and activated?
    – Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating)

    We will likely have a fix for this in our next upgrade, but to be sure we do – we’ll need as much information as possible from those of you who are experiencing this bug.

    *Please do not post unrelated issues in this thread. This thread is specifically for the error ‘Request URI Too Large.



Viewing 15 replies - 16 through 30 (of 39 total)
  • DArn, I should have looked here first before upgrading Nextgen …

    I have the same problem too. Everything was fine before …

    Photocrati, can you not just make it an option for us to choose if we want nextgen to detect js conflicts or not ? At least we can disable it if we don’t want it.

    Thanks … in the meantime reverting back to perfect old Nextgen 🙂

    Hi can someone share where to download the previous version? I assume I would just dump the files into the plugin directory?

    Go to the developers tab and you can download previous versions as a zip then upload.


    what @sahil1802 suggest didn’t work on my site, can’t add images to gallery or upload images, it gives me a blank page

    Well, just got the latest update from Nextgen, hope it works now …

    Where did you get the latest Nextgen update?

    @sahil, did disabling the conflict detection by changing TRUE to FALSE in nextgen-gallery > admin > admin.php line 60 fix the problem for you?

    if (!defined(‘NGG_JQUERY_CONFLICT_DETECTION’)) {

    @lilatovcocktail, Version 1.9.12
    Fixed: jQuery Conflict Detection was trying to dequeue irremovable scripts

    Just click on “Check Again” under WordPress Updates in your dashboard

    Fixed! Thanks for the heads up @astrasuite.

    I update my nextgen to 1.9.12 and have this

    if (!defined(‘NGG_JQUERY_CONFLICT_DETECTION’)) {

    in nextgen-gallery > admin > admin.php and adding the following to wp-config.php file, above the line that says “/* That’s all, stop editing! Happy blogging. */:


    and still got a blank page when trying to add a gallery

    I’m just guessing, but I think your additions to admin.php ares interfering with or countermanding the changes that were made to fix the problem in 1.9.12.

    Try returning to the unedited admin.php and then applying the upgrade. The upgrade fixed the problem completely for me.

    Ok, I back to the original admin.php but the problem still occur – got blank page when try to add a gallery 🙁

    Plugin Author photocrati


    Just to confirm and reiterate what has previously been said – v1.9.12 should fix this issue.

    @acesabre, I would suggest that you return all edited files to their original state. Then via FTP refresh your plugins files with a fresh downloaded copy of v1.9.12 of the plugin. Refreshing the Theme files directly should do the trick.

    @photocrati, I revert back all edited files to its original state, even the wp-config.php. I downloaded a fresh copy from wordpress site and put it via ftp to the server, one fixed but have another as I described in thread http://wordpress.org/support/topic/unable-to-create-new-gallery-or-upload-images-as-of-v1910-wp-35, also send to you a bug report with temp. login information. Did you use it ?

    No problem, lilatovcocktail, and all working for me too … that includes wp-smushit smushing files while being uploaded by Nextgen …

Viewing 15 replies - 16 through 30 (of 39 total)
  • The topic ‘[Resolved] Page Refreshes / Request URI Too Large’ is closed to new replies.