WordPress.org

Forums

Page Redirects (24 posts)

  1. AutoHelpRepair
    Member
    Posted 1 year ago #

    I am having an issue with my blog page. Blog page works fine going to page off the web. The issue is while in Admin panel, go to auto repair blog page and click preview it goes to my home page. See images in this link: https://drive.google.com/file/d/0B9_YIn2J4Rx0TWtHSXVTUHNVOGc/edit?usp=sharing

    Can any one help me with this?

    Thank you in advance,

    Master Tech Lee

  2. TychoMonolith
    Member
    Posted 1 year ago #

    Hi...

    Can you post the contents of your .htaccess file?

    Have you used a redirect plugin by any chance? Has this behavior always existed or is it something new? If new, did you recently make a change.

    We need more information.

    :)

  3. AutoHelpRepair
    Member
    Posted 1 year ago #

    Thank you for the quick reply, I will copy the .htaccess when GoDaddy fixes their server, ya - down again. No redirected plugins that I know. Do not know if this has been a problem in the past - all I know is some of my blogs are not indexing, and the other day I made a minor sentence change - went to preview it, and I noticed it was going homepage.

  4. AutoHelpRepair
    Member
    Posted 1 year ago #

    Is it safew to send .htacess file through this channel? no security issues with that?

    Lee

  5. AutoHelpRepair
    Member
    Posted 1 year ago #

  6. TychoMonolith
    Member
    Posted 1 year ago #

    Yes, safe to cut n' paste your htaccess here. No security issues.

    Let's see what we have in that file.

  7. AutoHelpRepair
    Member
    Posted 1 year ago #

    Here is the plugins and settings

  8. AutoHelpRepair
    Member
    Posted 1 year ago #

  9. TychoMonolith
    Member
    Posted 1 year ago #

    I'm gonna bet your "preview" issue has something to do with how large your .htaccess file is.

    The original .htaccess for wordpress is very simple:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Source: http://codex.wordpress.org/htaccess

    That's it.

    Compare to the file you pasted. BIG difference.

    So, here's what I would do. Save your current .htaccess somewhere safe. Then, create a new .htaccess, include just the snip above that we got from the codex and then see if that fixes your "preview" issue.

    I betcha it will. And if it does, then you'll know that your .htaccess is blowing something up. And more specifically, maybe it's the BULLETPROOF .50.1 plugin that is modifying your .htaccess file.

    Give that a shot and report back to us?

    We'll talk about plugins after you try the new .htaccess trick.

    Cool?

  10. AutoHelpRepair
    Member
    Posted 1 year ago #

    Will do thank you.

  11. AutoHelpRepair
    Member
    Posted 1 year ago #

    I did what you asked and does the same thing. Sorry, was hoping it would work.

  12. AutoHelpRepair
    Member
    Posted 1 year ago #

    do you have logmein to see what I see

  13. TychoMonolith
    Member
    Posted 1 year ago #

    I did what you asked and does the same thing. Sorry, was hoping it would work.

    Hrmmm...

    Did you make sure you cleared out your cache on your browser _after_ you re-did the .htaccess file?

    Gotta start with a clean slate.

  14. AutoHelpRepair
    Member
    Posted 1 year ago #

    No, Will do that . Thank you

  15. AutoHelpRepair
    Member
    Posted 1 year ago #

  16. TychoMonolith
    Member
    Posted 1 year ago #

    Ok...so, let's try this then:

    Do you have a totally different browser you can use? Looks like you're using FireFox...try "previewing" with Chrome or IE.

    What happens?

  17. AutoHelpRepair
    Member
    Posted 1 year ago #

    I checked IE, Fox, and chrome all the same

  18. AutoHelpRepair
    Member
    Posted 1 year ago #

  19. AutoHelpRepair
    Member
    Posted 1 year ago #

    This is the fox version I rechecked the .htaccess has the script you sent.

  20. AutoHelpRepair
    Member
    Posted 1 year ago #

    https://drive.google.com/file/d/0B9_YIn2J4Rx0SGo5eURlVGNJS0U/edit?usp=sharing

    Here is a video so you can see what happens in all browsers.

    Lee

  21. AutoHelpRepair
    Member
    Posted 1 year ago #

    TychoMonolith are you there?

    Master Tech Lee
    https://www.autorepairhelp.us

  22. TychoMonolith
    Member
    Posted 1 year ago #

    Annnnnnnnnnnnnnd....we're back.

    Did you change the color palette on your site? I see blue now.

    I'm checking on something for ya...hang on. Back in a sec.

  23. AutoHelpRepair
    Member
    Posted 1 year ago #

    Yes we are still in the construction phase if you need to talk live to me you can go to the Live support button and click it.

  24. TychoMonolith
    Member
    Posted 1 year ago #

    One more thing on the .htaccess front I'd like you to try.

    In the Settings → Permalinks panel, what do you have stored as the permalink structure? Please cut n' paste here.

    While you are there, SAVE the permalink structure again. Sometimes this helps resolve some issue in .htaccess if you are having problems on that front.

    The video you provided was useful. You are using the BLOG EXCERPT template for your blog. That's good. What is odd here is that when you are PREVIEWING, the URL you are previewing is http://www.autorepairhelp.us/auto-repair-blog/. You can see this in the browser address bar. The issue is that the content rendered is the homepage content. I'm thinking this might be a theme issue now.

    So, here's what we do there: Check your theme settings and compare to this:

    http://codex.wordpress.org/Creating_a_Static_Front_Page#WordPress_Static_Front_Page_Process

    Make sure you don't have the POSTS PAGE set to "home"

Topic Closed

This topic has been closed to new replies.

About this Topic