Support » Plugin: WP Notification Bell » Page Redirect isn’t Working with Premium Plugin

  • Resolved chipster0812

    (@chipster0812)


    I have downloaded the premium verison of WP Notifications Bell and I would like the bell icon to link to a page on my site and not show the drop down menu. However, no matter what I do in the settings, it’s not working. Is there anything special I should be doing to make this redirect work?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author wpdever

    (@wpdever)

    Hi,

    Have you added the url in the ‘Notification page url’ in the settings? If so, does it keep showing the drop down or does it redirect to the wrong link?

    Thread Starter chipster0812

    (@chipster0812)

    I have added it in the settings and it keeps showing the drop down. There is no redirect happening at all.

    Plugin Author wpdever

    (@wpdever)

    Which display option are you using? I was able to find the issue after testing the 2nd and 4th option (add floating icon and add badge count to existing menu item). Let me know if it’s one of these 2 so I can release an update.

    Thread Starter chipster0812

    (@chipster0812)

    I was using option 2 and 4 when I tested it. I would prefer to use option 4.

    Plugin Author wpdever

    (@wpdever)

    I’ve just released an update that should fix the issue. If you’re using option 4, you need to add your url in the ‘Notification page url’ field and in the ‘URL’ field in your menu item in Appearance->Menus.
    Let me know if it works on your side.

    Thread Starter chipster0812

    (@chipster0812)

    The redirect is now working, however, I am noticing that the number count or badge that shows how many notifications does not go away even when you read the notification. Is there something I need to do to make that go away once the user clicks on the bell/notification?

    Plugin Author wpdever

    (@wpdever)

    Did you find this problem in both options 2 and 4? And do you open the page in a new tab or the same one?

    Thread Starter chipster0812

    (@chipster0812)

    Yes, i find the problem in both options 2 and 4. The page opens in the same tab.

    Plugin Author wpdever

    (@wpdever)

    I can’t replicate this issue but I can try to add something in the notification page. Which shortcode do you use to display notifications on the page?

    Thread Starter chipster0812

    (@chipster0812)

    I’m using the shortcode [wp-notification-bell-notifications]. I just retested it with option 2 and added new notifications and it still says 2 notifications even after clicking the bell and reading the notification.

    Thread Starter chipster0812

    (@chipster0812)

    I have tried again today with option 3 by putting in the short code to a page and no matter what I do, it always says the number of notifications and does not go away.

    Plugin Author wpdever

    (@wpdever)

    I’ll release an update in a few hours to fix it. I’ll leave a message here to let you know.

    Thread Starter chipster0812

    (@chipster0812)

    Okay, thank you for the update! I appreciate the help.

    Plugin Author wpdever

    (@wpdever)

    I just released an update that should fix the problem with logged in users. I’ll release another one for logged out users as soon as I can.
    Let me know if it’s fixed on your side.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.