Support » Plugin: Before And After: Lead Capture Plugin For WordPress » Page protection always loops back to form

  • Resolved TEMPOStrategic

    (@tempostrategic)


    Hi,

    I am using this with Gravity Forms on a landing page. The goal is to collect name and email and submit. After goal success the redirect goes to a page with a webinar recording. It works fine if I do not enable page protection. Once I enable page protection even if the form is successful submitted it loops me back to the form page.
    Any suggestions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author richardgabriel

    (@richardgabriel)

    Hey @tempostrategic!

    The behavior sounds like the Goal isn’t being completed, and therefor you are being redirected to the Goal to be completed when you visit the Protected page.

    I’ve usually only seen issues with Goals not completing when the Form and Goal aren’t setup correctly together or when there is a caching issue with the site.

    If you’d still like help, I’m happy to do so, however I probably need to login to your site to see how you have this setup.

    Best,
    Richard

    TEMPOStrategic

    (@tempostrategic)

    Richard,
    Thank you for the follow up. I have monitored the goal page and destination and I only get a few visits directly of people circumventing the goal. Does not seem to be a big problem right now. If I see more people start to visit the page I may look into this again. Thanks.

    BTW. The site is on WP Engine and is using Cloudflare so caching could be the issue.

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey @tempostrategic!

    Thanks for letting me know!

    If this is an active problem I will see if I can continue to investigate it. Just let me know!

    FYI, when I’ve seen other reports like this it is due to the Goal not actually being completed. Usually this happens with another plugin, such as Ninja Forms, where the [complete_goal] shortcode is required to trigger completion. Since we have a direct integration with Gravity Forms this shouldn’t be an issue, but I wanted to mention it since its topically related.

    All the best,
    Richard

    TEMPOStrategic

    (@tempostrategic)

    Richard, Thanks again for the follow up on this. I have not resolved this, but it did not turn out to be an issue since we only have minimal amount of visitors accessing the page directly and I do not want to spent anybody’s resources unless it is an issue that needs to be fixed. If that status changes I will surely take you up on your suggestion.
    Thanks,
    Boris

    Hi! I came across the same problem on my site, also hosted on WPEngine. I chatted with their support and they confirmed it is a caching issue with the server. They were able to add an exception for the url of the gated content and cookie name, which solved the problem for me.

    To note: Turning object caching off in the WPEngine User Portal does not fix it. There was something else they needed to do on their end. Unfortunately, I did not get the exact details so I cannot be more specific.

    Just wanted to put this in here in case others run into the same issue.

    @kayceedub . Thank you, that is great to know since I have all my clients on WPengine or will move them soon and I am sure it would have come up again.

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey @kayceedub @tempostrategic!

    Thanks for the input on this!

    We will be sure to update our documentation to reference the new requirements for disabling the WP Engine content cache on Before & After pages.

    All the best,
    Richard

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Page protection always loops back to form’ is closed to new replies.