Page permalinks - Mod rewrite not this issue (i think) (18 posts)

  1. jimothyinnothy
    Posted 6 years ago #

    Hi All,
    Been playing with WP for a long time, and never really encountered any trouble with it. But today is different.
    Have been asked by a friend to sort their wordpress out, and me being me said "yeah sure, no worries!".
    Wish I hadn't!

    So to the problem.
    Wordpress 2.84, freshly installed.
    Got Mod rewrite installed, and the allow overides is on "all" and .htaccess is in the webroot, is writeable, and wordpress can write to it. So I trust that works. I have conducted a mod_rewrite test with some files I use to test, and indeed the server does respond as it should do.
    I have created a series of pages, and the permalinks are set to http://www.mydomain.com/about or /home or whatever, and in permalinks structure settings I have it set to custom: %postname%/
    All I get when I view a page, is the template, with a 404 error, "page no longer exists" in it. I switch off permalinks, and visit the page with the /p=13? (eg ;)) url and sure enough our data is there.
    So what to do, I turn my hand to the might of the WordPress support forums and beg for assistance.....Im very sad..... :(

    Thanks in advance all, any help will be greatly appreciated.


  2. greatbig47
    Posted 6 years ago #

    Same kind of help needed here


  3. jimothyinnothy
    Posted 6 years ago #

    Hi Greatbig. Be sure you have your server set up correctly, I am damn sure mine is, hence the post here. If your server does not have its apache config entries setup correctly, then you will get this error.......
    Is it your own server or shared hosting?

  4. Mark / t31os

    Posted 6 years ago #

    Tried with FollowSymLinks? Or do you have this in your htaccess already?

    Further info:

  5. jimothyinnothy
    Posted 6 years ago #

    Thanks for the respons, the contents of the htaccess file are as follows:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Which is what I found on the wordpress support site, and what wordpress writes to the file itself if given teh opportunity.
    Can you give me a few pointers on the follow symlinks route? Not too familiare with that.


  6. Mark / t31os

    Posted 6 years ago #

    Place this above the WordPress stuff..

    Options +FollowSymlinks

    ..and see if that helps..

  7. jimothyinnothy
    Posted 6 years ago #

    No joy sadly. :(

  8. Mark / t31os

    Posted 6 years ago #

    Try without the + infront of FollowSymLinks.

  9. greatbig47
    Posted 6 years ago #

    I'm using wpmu and I am an HTACESS, PERMALINKS, FOLOOWSYMLINKS newb to the gills...

    and I'm scared...

    I host via Dreamhost

    SOOO close to getting everything working, and it all goes down hill so fast..


  10. Mark / t31os

    Posted 6 years ago #

    Is it not clear what you would do based on what's posted above?

  11. jimothyinnothy
    Posted 6 years ago #

    Greatbig, I would get on to dreamhost and check apache is configured correctly first.

    t31os, that had no effect either :(

  12. Mark / t31os

    Posted 6 years ago #

    If WordPress is in a sub-directory, any htaccess files in parent folders will have an effect, so if you're using a sub-directory, check if the parent directories have a htaccess file, and if so see if removing/renaming it temporarily helps.

    Or perhaps it would be benefitial to speak with your host, telling them you are having a problem using Symbolic Links.

    There shouldn't be any need to mention that you're using WordPress, just simply that Symbolic Links won't work, they should be able to advise you on how to use Symbolic Links with their service.

  13. jimothyinnothy
    Posted 6 years ago #

    Is that for me?lol
    Too confusing, two support requests in one ticket!

    The server is my own, and symlinks do work, I am using them all over the place, so I dont think it is that, although I am willing to be proven wrong. The installation is in the doc root, not in a subdirectory. This is why I am stumped, this *should* work.

  14. Mark / t31os

    Posted 6 years ago #

    This may sound silly, but you tried re-setting your permalinks..

    Re-setting, not resetting... as in, changing them to something else, saving them, and then reapplying the new settings again..

  15. jimothyinnothy
    Posted 6 years ago #

    Nope, but will give it a go now :)

  16. jimothyinnothy
    Posted 6 years ago #

    Nope, no joy there either.
    This really is baffling. Its either going to be something stupidly complicated or really stupidly simple.


  17. Nile Flores
    Yoast Support
    Posted 6 years ago #

    Just as a clarification, you put %postname%/

    Did you mean you really put -


  18. Mark / t31os

    Posted 6 years ago #

    Assuming you have neither, what if you add a category and tag base under the permalink settings?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.