Support » Fixing WordPress » Page permalinks do not work? (1.5)

  • There’ve been enough posts about this that I thought a separate solution thread was in order…

    If after upgrading to 1.5 you find links to *static* Pages, specifically when using custom permalinks, cause 404 errors, you want to:

    1. Copy the contents of your .htaccess file to a file on your pc.
    2. Edit out all .htaccess contents and save it through Manage > Files.
    3. Reset your permalink structure (Options > Permalinks, click Update Permalink Structure).

    In most cases .htaccess will be written to automatically. If not, copy the rewrite code WordPress generates to a text file and upload that as your .htaccess file (or edit it online — Manage > Files).

    Any custom (non-WP generated) rewrite rules you may have had can be copied into .htaccess, but I recommend adding them to the end of the file (after # END WordPress).

    Further information on editing .htaccess can be found here (when the link is working again):

Viewing 15 replies - 1 through 15 (of 15 total)
  • This solves my 404 problem – for the moment, but based on the new rewrite code, I have to update my .htaccess any time I add a page… There’s got to be an easier way!

    Thanks. Question, do I need to have WP update the .htaccess each time I add a static page? Or can I change ther permissions on the server to read only?

    Thanks again

    Each time you add a page, you’ll need new rewrite rules, so you’ll either have to let WP edit the file or manage it yourself.

    What about 403? I am getting 403 errors when I try to access my static pages.

    This is the error page:
    You don’t have permission to access /about/ on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I tried the above solution but it didn’t work. WordPress did create a new htaccess file, but I still get the error. I was getting these errors before with the comments, and changed the chmod permissions to fix it, but as these are virtual folders, I can’t do that. Any suggestions?

    mine gives 404, 403 and then good ole generic “internal server error” after a while.

    Dammit, I REALLLY need this to work for Search engine work I do.

    how much and who do I have to pay to fix this?

    anyone use this plugin with success?

    Ryan Boren


    WordPress Dev

    Many people have. There is a caveat however. Path info processing must be enabled. If you use Apache 2.0.30 or later, you can add the following to your .htaccess to make sure it’s on.

    <Files "index.php">
    AcceptPathInfo On

    I’m on an apache 1.3.33 so most solutions won’t work. Now my urls read right but give me 404s instead of permalinks, and DELETING the info out of .htaccess and trying to put the permalinks back the way they were doesn’t work.

    chmod on .htaccess is currently set to 666 and the .htaccess is altered as it should be for the change to work. And I still get a 404 on permalinks.

    Why isn’t there a “reset to default” on this??? That seems to be a BIG oversight.

    Can anybody help?

    Okay, so in the absence of answers I tried that plugin, reduced rewrite. Now I just get a broken 404 with my images thrown around and nothing where it belongs- which used to not be the case. In fact the 404 is REALLY bizarre. It missed ONE image in my php generated html from header, it missed ONE image from my styles.css, and it threw out my search box entirely, which causes everything to float left in a disastrous way.

    Apparently Apache 1.3.33 does not handle this kinda stuff well. And I didn’t even TRY to use the category in the new permalink url.

    All I wanna do is restore the default and say the hell with this. It broke something that used to work. How do I do that? Do I have to do a reinstall? Or can I selectively upload something?

    kickass, I just want to second this.
    Me having the same problem, just wanting to get back to the condition of un-altered internal WP- and Permalinks.
    The thing is, apparently, that my free host does not support mod_rewrite, probably neither AllowOverride; since it is a free service, I couldnt blame him.

    Whenever I try to procede as so helpfully described (1, 2), I get something like this: deleting the .htaccess-file brings my WP-blog back, but the links keep their ‘updated’ structure — when I click on them I get a 404.
    When I upload a blank .htaccess-file just to get it filled with proper, un-altered Permalink-information, the very moment I click the “Update Permalink”-button I get a 404!
    That is: I’m trapped! What can I do? I just want to get back my un-changed ‘classical’ Permalinks.
    Please, help would be greatly appreciated!

    so if im one of the lucky ones in this whole, create a new page have to update the htaccess file. if im lucky all i should need to do is create a page, go to options>permalinks and simply update, and have my chmod htaccess set to 666 or WP writable friendly and then they will be updated automatically, but if im unlucky id have to update the htaccess myself? well i think i got the lucky stick for once. pages werent working, then simply clicked update permalinks and bada bing, theyre working again. guess i just have to click it every time i alter a page.


    I’m having this exactly same problem. Isn’t there a “fix” for this? — OUT OF DALANZADGAD is my page and it doesn’t come up. I even did the updating of the .htaccess file (including letting WP write to it). No luck.

    **Nevermind, I used this fix & I’m good to go:*

    I’m having the exact same problem, but clearing out my .htaccess file & updating my permalink structure did not work.

    My .htaccess is set to chmod 666, and it won’t re-write it for me. I’m using wordpress 1.5.2.

    I had created a page before my upgrade and the rewrite rules were automatically written to my .htaccess, now it won’t do a thing for Pages. for posts, it’s just fine. – I can manually add the rewrite rules, but this is a pain in the arse.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Page permalinks do not work? (1.5)’ is closed to new replies.