[resolved] Page not jumping to comments section. (3 posts)

  1. fokjulle
    Posted 8 years ago #

    I don't really know how to search for this topic, in these forums, so I do apologise. However, please direct me if this has already been discussed.

    I've had a 'paged-comments' plugin running for some time now, and have decided to remove it. I've since discovered that, when one clicks on "leave a comment" under the blog post, the page no longer jumps to that comment form (like it usually does).

    Instead, it loads the post (as per usual) but instead of taking the user to the comment form, it simply stays at the top of the blog post, meaning that the user has to scroll down to the comment from.

    I may have removed a simple line of code or something, but I've no idea how to fix this. Anyone with a quick solution?

  2. BPartch
    Posted 8 years ago #


    In the default theme, in comments.php there is an anchor declared right above the Leave a Response heading:

    < a name="respond" ></ a >
    <h4 class="respond">Leave a Response</h4>

    *** No spaces in the anchor above ***

    Then when you link to this page from the add a comment or whatever you can add #respond to the end of the link:

    Like so:

    Not sure if you are using the default theme (or one derived from it) but this can be added is needed. :)

  3. fokjulle
    Posted 8 years ago #

    That was it, thanks. Perfect.

Topic Closed

This topic has been closed to new replies.

About this Topic