Support » Fixing WordPress » Page not getting updated

  • artisticallyaparna

    (@artisticallyaparna)


    I am trying to create a new page, once completing the structure and published – It’s publishing forever…. If I reload, then I lose what I have done and have to do it from scratch. I have been trying this for 3-4 times yesterday and today, but still the same issue.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Aniket

    (@aniash_29)

    Hi @artisticallyaparna,

    What WordPress version are you running? Did you recently update WordPress, any plugins or your active theme?

    You can try debugging the issue by observing Developer Console using F12 on Chrome/Firefox while loading the Edit Page screen. Navigate to the console tab on the Inspector console. See if you notice any errors or warnings. Most probably, this is a JS issue.

    artisticallyaparna

    (@artisticallyaparna)

    I can see the below 2 issues,

    > Indicate whether to send a cookie in a cross-site request by specifying its SameSite attribute
    > Indicate whether a cookie is intended to be set in a cross-site context by specifying its SameSite attribute

    Aniket

    (@aniash_29)

    Those should just be warnings and not errors.

    You will need to perform a step-by-step debugging to find out the root cause of the issue. It is most likely due to a plugin or current theme. I see that you’re running WordPress version 5.5, hence the chances are that this is a compatibility issue.

    In order to debug if this is being caused by any custom theme or plugins, you could try deactivating all plugins and then try activating them back one by one. If that doesn’t help try switching to one of the default (Twenty*) themes. If deactivating your current theme solves it, then the issue was likely your current theme.

    artisticallyaparna

    (@artisticallyaparna)

    Thanks Aniket…. I tried deactivating plugins from the admin page, but when I do that it says “The link you followed has expired” and does not deactivate

    artisticallyaparna

    (@artisticallyaparna)

    Tried with “Twenty” theme, still the same,… Got this error message “Failed to load resource: the server responded with a status of 403 ()”

    Aniket

    (@aniash_29)

    Hi @artisticallyaparna,

    It then drills down to a conflicting plugin. The link you followed has expired message could probably arise due to cookies not being set on the browser, an expired WordPress session. You could try logging out and logging in back and then try again.

    If that doesn’t work, and if you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    If you are not able to install, activate or deactivate any plugins from WordPress dashboard, you will need to do it manually. This article should help you: https://www.wpbeginner.com/plugins/how-to-deactivate-all-plugins-when-not-able-to-access-wp-admin/.

    artisticallyaparna

    (@artisticallyaparna)

    Appreciate your efforts it solving this Aniket… I was able to install HealthCheck but nothing after that… I was able to turn off all plugins and turn back on, but no use… Tried twenty’s theme, but it never gets updated…

    Anything I try to do within the admin page, I get the same error “the link you followed has expired”

    artisticallyaparna

    (@artisticallyaparna)

    @aniash_29 I simply used another laptop, and it worked…. everything works fine on that laptop… I guess something wrong with this browser…. Appreciate it

    Aniket

    (@aniash_29)

    So, it was indeed a browser cookie issue. Anyways, glad it worked and the issue is resolved.

    Cheers!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.