WordPress.org

Forums

WordPress HTTPS (SSL)
page not found when redirecting to https (2 posts)

  1. haimari1
    Member
    Posted 1 year ago #

    Installed the plugin and configured pages (checkbox)
    This works and those pages are going through https.

    But:

    When I replace the https with http at the browser I get page not Found instead of being redirected to the same page with https

    The problem could be related to using Hebrew characters:

    "https://www.example.com/%D7%99%D7%A6%D7%99%D7%A8%D7%AA-%D7%97%D7%A9%D7%91%D7%95%D7%9F/test/create-form/"

    This page works fine when I first go to it
    But then I remove the "s" from the https://... and hit enter
    And i'm redirected to:

    "https://www.example.com/-/test/create-form/"

    Please advise,
    Thank you

    https://wordpress.org/plugins/wordpress-https/

  2. socsolu
    Member
    Posted 1 year ago #

    This seems to be an issue with pages beyond the initial top layer.

    i.e.

    http://example.com > https://example.com (works)
    http://example.com/page1 > https://exmaple.com/page1 (works)

    but

    http://example.com/folder/page2 > https://example.com/folder/page2

    On my site, it changes adds "~b2382149"

    http://example.com/folder/page2 > https://example.com/~b2382149/folder/page2

    Which then serves up a 404 error

    I'm serving up the whole site on https by using a URL filter of "/"

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic