Support » Fixing WordPress » Page Not Found – Http 404

  • mames40

    (@mames40)


    Hi,
    I have a wordpress site that got hacked with malware redirection. It has been cleaned but now my custom menu doesn’t work the links are permalinks (see below). I get a http 404 when I try to access the link. Also when I type in the browser http://elliotequineconnections/71-2/ I get a Http 404. Any insight into my problem would be most appreciated

    <!– Start css3menu.com BODY section id=1 –>
    <ul id=”css3menu1″ class=”topmenu”>
    <li class=”topmenu”>Home
    <li class=”topmenu”>Horse Training
    <li class=”topmenu”>Lessons
    <li class=”topmenu”>Sale and Events
    <li class=”topmenu”>Bio
    <li class=”topmenu”>Contact
    <li class=”toplast”>Doterra

    <p style=”display:none”>Vertical Drop Down CSS Menu Css3Menu.com</p>
    <!– End css3menu.com BODY section –>

Viewing 5 replies - 1 through 5 (of 5 total)
  • DJDoubleXL189

    (@djdoublexl189)

    Did you reinstall the code for your menu?

    Were those the right urls/links before?

    mames40

    (@mames40)

    Hi,
    Yes I reinstalled the code for my menu. I double checked that the permalinks were the same. I submitted a trouble ticket to HostPapa. They said that my .htaccess file did not have the rewrite rules for the permalinks to work. Does that sound right? Before I sent the .htaccess file to them and there was just one rewrite rule for index.php. This is before I had problems with the links not working.
    So I am questioning if that is right. Does that sound right to you?

    Alexanderine

    (@alexanderine)

    It actually makes perfect sense, the htaccess file is the cause of everything, i also want you to check in your wordpress general dashboard >> settings , make sure that the wordpress & the site address has the same url. Sometimes that changes and can cause trouble.

    mames40

    (@mames40)

    Thanks for your help. The .htaccess file was restored and it worked!

    Alexanderine

    (@alexanderine)

    So the urls in dashboard were really different !! 🙂
    Am glad it worked man, i spent 2 hours deactivating plugins one by one, the turns out there’s a an extra W in my wordpress url in admin general setting 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Page Not Found – Http 404’ is closed to new replies.