Support » Plugin: DCO Comment Attachment » Page not found – After attaching image more then 20kb or 50kb

  • Resolved atiq97

    (@atiq97)


    Whenever i try to upload image larger than 50kb it shows an error ( page not found )

    There’s only comments.php in theme folder Here’s its code:

    
    <?php
    /**
     * The template for displaying comments
     *
     * This is the template that displays the area of the page that contains both the current comments
     * and the comment form.
     *
     * @link https://developer.wordpress.org/themes/basics/template-hierarchy/
     *
     * @package CoverNews
     */
    
    /*
     * If the current post is protected by a password and
     * the visitor has not yet entered the password we will
     * return early without loading the comments.
     */
    if ( post_password_required() ) {
    	return;
    }
    ?>
    
    <div id="comments" class="comments-area">
    
    	<?php
    	// You can start editing here -- including this comment!
    	if ( have_comments() ) : ?>
    		<h2 class="comments-title">
    			<?php
    			$comment_count = get_comments_number();
    			if ( 1 === $comment_count ) {
    				printf(
    					/* translators: 1: title. */
    					esc_html_e( 'One thought on &ldquo;%1$s&rdquo;', 'covernews' ),
    					'<span>' . get_the_title() . '</span>'
    				);
    			} else {
    				printf( // WPCS: XSS OK.
    					/* translators: 1: comment count number, 2: title. */
    					esc_html( _nx( '%1$s thought on &ldquo;%2$s&rdquo;', '%1$s thoughts on &ldquo;%2$s&rdquo;', $comment_count, 'comments title', 'covernews' ) ),
    					number_format_i18n( $comment_count ),
    					'<span>' . get_the_title() . '</span>'
    				);
    			}
    			?>
    		</h2><!-- .comments-title -->
    
    		<?php the_comments_navigation(); ?>
    
    		<ol>
    			<?php
    				wp_list_comments( array(
    					'style'      => 'ol',
    					'short_ping' => true,
    				) );
    			?>
    		</ol><!-- .comment-list -->
    
    		<?php the_comments_navigation();
    
    		// If comments are closed and there are comments, let's leave a little note, shall we?
    		if ( ! comments_open() ) : ?>
    			<p class="no-comments"><?php esc_html_e( 'Comments are closed.', 'covernews' ); ?></p>
    		<?php
    		endif;
    
    	endif; // Check for have_comments().
    
        comment_form();
    	?>
    	
    
    </div><!-- #comments -->
    

    Please guide me

    • This topic was modified 1 year, 4 months ago by Yui. Reason: please use CODE button for code formatting

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter atiq97

    (@atiq97)

    I already did so many effort by following your articles, no success

    Plugin Author Denis Yanchevskiy

    (@denisco)

    Hello @atiq97,

    If you use these recommendations and choose the second option, then you need

    2. Make a copy of wp-comments-post.php and name it blahblah.php.

    after that you need replace comment_form(); with comment_form(array('action' => '/blahblah.php')); in your comments.php file.

    This is a hosting issue, so unfortunately I can’t fix it in the plugin.

    Thread Starter atiq97

    (@atiq97)

    I already tried that, that’s not working. Even that don’t attach the smaller file as well. Just return the error of 404

    Thread Starter atiq97

    (@atiq97)

    and no, this isn’t hosting related issue, i am reproducing it on localhost, and its same there as well

    Thread Starter atiq97

    (@atiq97)

    Here’s the Link to theme file

    Plugin Author Denis Yanchevskiy

    (@denisco)

    I made fresh install of WordPress and your theme and DCO Comment Attachment plugin. I can’t reproduce this issue. Video 1.86 MB uploaded without any problems.
    Here video demonstration.

    Thread Starter atiq97

    (@atiq97)

    What should I say to my hosting? I see it working on my same company other server as well but not current

    Loved your help

    Thread Starter atiq97

    (@atiq97)

    Also please mark it as resolved. If you can give suggestion or not. no problem. i am developer myself, was checking additional issues for urgent, and gladly you helped

    Plugin Author Denis Yanchevskiy

    (@denisco)

    What should I say to my hosting? I see it working on my same company other server as well but not current

    I think you need to try asking just that: “Why it working on my same company other server as well but not current?”

    If you can give suggestion

    The main problem is that I don’t know the exact cause of this issue. I have only a few reports of a problem with similar symptoms and some of them mention HostGator hosting (I made a quick research: 1, 2, 3, 4, 5, 6). Therefore, my assumption is that the reason is in some limitations of this hosting. I will be glad if you share a successful case, if you can get to the bottom of the matter.

    I’m having the same issue and I’m with Bluehost who swear it has nothing to do with them. No matter what I try, nothing works. If you don’t know what the cause is I’m hoping you’ll inform us if/when you do?

    Thread Starter atiq97

    (@atiq97)

    Hey @jbertrand3000 . I have changed my hosting. Bluehosting wasn’t solving the issue.

    Have look at https://dirtworld24.com/past-memories/ It’s working perfectly now

    Thread Starter atiq97

    (@atiq97)

    @denisco , I had looked into the issue, It’s security restriction from them ( They don’t allow server ssh access on shared hosting to overwrite the changes ) So the best solution is not to use them. So far I have tested this plugin on:

    Siteground
    Namecheap
    Digital Ocean
    Kinsta
    A2hosting
    and Localhost

    and everywhere its working perfectly.

    @atiq97 So you’re saying it is Bluehost regarding the ssh access?

    Plugin Author Denis Yanchevskiy

    (@denisco)

    I had looked into the issue, It’s security restriction from them ( They don’t allow server ssh access on shared hosting to overwrite the changes ) So the best solution is not to use them. So far I have tested this plugin on:

    Thank you for sharing the solution and testing.

    Marking as resolved. Feel free to reopen this topic, or create a new one if you have another questions.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Page not found – After attaching image more then 20kb or 50kb’ is closed to new replies.