Support » Theme: Fifteenth » Page layout issue

  • Hi, I found that if I select ‘full width page’ from the WordPress template options for any given page, nothing renders. I was expecting to have a full width page (no sidebar) but nothing rendered at all; I just see the site header and background.
    Any suggestions?
    Thanks.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Could you link the site?

    http://69.195.124.186/~bevyoung/crystalmedicinejewelry/

    The About page is set to full width page.

    Thanks.

    Did you make the template your self?

    Something must be wrong in the full width page php file.

    If you didn’t make it, try re installing or grabbing the full width php file and replacing it.

    If you made it your self you will have to post it so we can examine it for faults.

    I didn’t make anything myself, I just customized the theme with css. Where can I grab a clean copy of the full width php file to replace?
    Thanks!

    Woops, never mind, I just downloaded the theme from the theme page, I’ll see if I can compare the two.

    I switched the old full width php file with the one from the theme copy I just downloaded. No difference. Here is the code:


    <?php
    /**
    * Template Name: Full Width Page
    *
    * @package Fifteenth
    * @since Fifteenth 1.0
    */

    get_header(); ?>

    <div id="primary" class="content-area">
    <main id="main" class="site-main" role="main">

    <?php
    // Start the loop.
    while ( have_posts() ) : the_post();

    // Include the page content template.
    get_template_part( 'content', 'page' );

    // If comments are open or we have at least one comment, load up the comment template.
    if ( comments_open() || get_comments_number() ) :
    comments_template();
    endif;

    // End the loop.
    endwhile;
    ?>

    </main><!-- .site-main -->
    </div><!-- .content-area -->

    <?php get_footer(); ?>

    I also deactivated all plugins including custom css but nothing changed. Any ideas?
    Thanks…

    Theme Author Brian Harris

    (@zgani)

    Sorry about this, there is a bug in header.php while checking if the page the template is being used is/isn’t a bbpress forum page.

    A temporary fix is to remove the && !is_bbpress() @line 56.

    I’ll put out an update as soon as possible.

    Zulf

    Thanks, it worked I guess?

    http://69.195.124.186/~bevyoung/crystalmedicinejewelry/about/

    It got rid of the menu but left the widgets, is that what is supposed to happen? I was thinking the widgets would be gone too.

    Thanks.

    Theme Author Brian Harris

    (@zgani)

    Yes, the full width template will get rid of the menu and it should also remove the widgets too.

    As you are working with a modified (child theme?) version its difficult to has a guess as to what is going on. On my end the template behave as it should.

    Any chance you can send me a copy of your version so that I can take a look at it for you? If so please drop a copy here – you’ll need to be registred and logged in to see the upload button.

    Do you mean my stylesheet?

    I guess not…I can’t upload a css file. I didn’t create a child theme I can zip and send you.

    Theme Author Brian Harris

    (@zgani)

    Yes, if you can zip a copy of your modified version and send it over I’ll have a look at it for you.

    I sent it just now.

    Theme Author Brian Harris

    (@zgani)

    Got it but its just the stylesheet. Which is actually broken due to bad formating like font-family: '\Droid Sans\', Arial, sans-serif; – adding the backslash breaks any css code below that line.

    Can you send me the entire theme please so that I can see how this stylesheet is being enqueued?

    Uh-oh. The custom css plugin I’m using put the escapes in there. I need to fix it. Ack! Thanks for pointing it out. I will send the zip file of the theme…but I didn’t create a child theme.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Page layout issue’ is closed to new replies.