Support » Fixing WordPress » Page ID doesn’t change on each page

  • Resolved raspberryh

    (@raspberryh)


    I’m only having this issue on my mobile phone and on my ipad (and others are having it on mobile as well). The links work fine on desktop.

    When I click on a link, the URL at the top of the page changes (e.g., goes from /how-it-works to /contact-us) but the page title/content/etc shows the first page that you visited from the website. E.g., if you go to the homepage, every page you go to after that will display the homepage content.

    Furthermore, I am echoing the page id, and the page ID does not change when you switch pages. The page ID stays as the same page you started on.

    I tried the following:
    – Uninstalled all plugins
    – Switched to 2020 theme
    – Updated everything (PHP version, WP to 5.7.2, all plugins)
    – Resetting permalinks in Settings -> Permalinks

    As for changes made before this started happening, my manager says she only went in and made text changes. However, I don’t know how long this has been going on for. I only noticed it today. But I’m pretty sure I’ve gone to the website on mobile many times before and it worked.

    Any suggestions? I could not find anyone with a similar issue on Google.

    Site Info:

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: en
    user_language: en
    timezone: +00:00
    permalink: /%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-active-theme ###
    
    name: Claytopia (claytopia)
    version: 1.3
    author: the WordPress team
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, custom-logo, post-thumbnails, menus, html5, post-formats, editor-style, customize-selective-refresh-widgets, custom-background, custom-header, widgets
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty: version: 1.7, author: the WordPress team
    Twenty Twenty-One: version: 1.3, author: the WordPress team
    
    ### wp-plugins-active (6) ###
    
    Akismet Anti-Spam: version: 4.1.9, author: Automattic
    Contact Form 7: version: 5.4.1, author: Takayuki Miyoshi
    Facebook for WordPress: version: 3.0.5, author: Facebook
    Huge IT Slider: version: 4.0.5, author: Huge-IT
    Limit Login Attempts: version: 1.7.1, author: Johan Eenfeldt
    WP Mail SMTP: version: 2.8.0, author: WPForms
    
    ### wp-plugins-inactive (1) ###
    
    Check & Log Email: version: 1.0.1, author: WPChill
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1802
    imagemagick_version: ImageMagick 7.0.10-10 Q16 x86_64 2020-07-22 https://imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 62 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 12288
    	imagick::RESOURCETYPE_MAP: 62 GB
    	imagick::RESOURCETYPE_MEMORY: 31 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32-954.3.5.lve1.4.82.el6.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.11 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.71.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.49-cll-lve
    client_version: 5.6.49
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### wp_mail_smtp ###
    
    version: 2.8.0
    license_key_type: lite
    debug: No debug notices found.
    db_tables: wp_wpmailsmtp_tasks_meta
    lite_install_date: Jun 14, 2021 @ 4:02pm
    
    

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Topher

    (@topher1kenobe)

    Does it do it even if you’re logged in? This smells a LOT like a caching issue. It’s doing it for me on desktop as well.

    Thread Starter raspberryh

    (@raspberryh)

    Oh how weird, I totally thought it wasn’t doing it on desktop but it IS doing it on desktop for me too. I must have been mistaken! So yes it does appear to do it whether or not I am logged in. It does sound like it is a caching issue but I can’t imagine what would make it happen? A PHP setting? Any ideas? Thanks so much for looking!!

    Thread Starter raspberryh

    (@raspberryh)

    Update – I’ve added define(‘WP_CACHE’, false); to wp-config.php. And it appears to be fixed on desktop but not on mobile. I cleared my cache and cookies on my mobile phone and am still getting the issue. I am going to try installing a cache plugin and see if that changes anything.

    EDIT: Actually I just realized it’s what you mentioned before, re: being logged in!

    EDIT: I was wrong, it’s broken everywhere now. UGH.

    • This reply was modified 3 months, 1 week ago by raspberryh.
    • This reply was modified 3 months, 1 week ago by raspberryh.
    Thread Starter raspberryh

    (@raspberryh)

    Hi, I have found that php REQUEST_URI doesn’t change when going to a new page. I installed a brand new fresh version of WP in a new directory and with new DB tables and I have the SAME problem. This would have to be a server issue, right? I called the webhost (godaddy) and he could not figure it out.

    Thread Starter raspberryh

    (@raspberryh)

    I believe I fixed it! I’m adding my solution in case anyone else has the same issue.

    I added this to my htaccess file to disable caching:

    <IfModule mod_headers.c>
        Header set Cache-Control "no-cache, no-store, must-revalidate"
        Header set Pragma "no-cache"
        Header set Expires 0
    </IfModule>
    
    <FilesMatch "\.(css|flv|gif|htm|html|ico|jpe|jpeg|jpg|js|mp3|mp4|png|pdf|swf|txt)$">
        <IfModule mod_expires.c>
            ExpiresActive Off
        </IfModule>
        <IfModule mod_headers.c>
            FileETag None
            Header unset ETag
            Header unset Pragma
            Header unset Cache-Control
            Header unset Last-Modified
            Header set Pragma "no-cache"
            Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
            Header set Expires "Thu, 1 Jan 1970 00:00:00 GMT"
        </IfModule>
    </FilesMatch>
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.