Support » Themes and Templates » page format problem with IE

page format problem with IE

  • hi

    i have a small problem with IE. My site pixelmania didn’t show up right when using IE:
    – in the header the pagename is cut off
    – the pictures in the posts are not aligned well

    both things are working well in fire fox

    i only changed the text size and the margin given in the style.php of the theme for the header.

    i am using the water 3 1.0 theme from the undersigned

    did anyone have a hint for me?

    thanks in advance

Viewing 13 replies - 1 through 13 (of 13 total)
  • any suggestions

    did no one have any suggestions about this issue?

    i thought that if the page is xhtml valid it should be rendered correct on both platforms – but as for now it seems that only the good old firefox is able to render the page correct …

    did anyone else have similar problems with a theme?

    Justin Tadlock


    WordPress God

    First off, just because something validates doesn’t mean that it will look right in all browsers.

    You should provide a link to the theme, so someone can take a look at it.

    I see how the site name looks covered up. You should play around with the margin and the line-height until you get something working.

    i am using water 3 version 1.0 from the theundersigned

    yes this with the sitename is such an issue: but the point is, that this problems occure only with IE. Firefox diplays the whole page completly correct.

    Justin Tadlock


    WordPress God

    I can’t even get the theme to work at all. It wouldn’t hurt to have some instructions with his theme on how to set this thing up.

    hmm this is weird. i had no problems installing the theme (only extraced to the wp-contenbt/themes and enabled it via the configuration panel …)

    there is no additional setup neccessary …

    Justin Tadlock


    WordPress God

    Okay, I finally got the theme to work. By the way, when I ask for a link to the theme, I meant a link to the theme (Water 3). Not the website because the theme listed under his download section is Water 1.

    There’s two things that need to be changed for this to work: in your “style.php” file — #title and #topmenu

    Locate those in the file. They’re close to the top and next to each other.

    Under #title you need to change the line-height: to something like 35px.

    Under #topmenu you need to change the margin-top: to something around 55px.

    You mentioned you changed the text size and the margin in the #header but I’m assuming you meant the #title since the header doesn’t have a text size.

    The original #title had:

    margin:38px 5px 0 0;

    The numbers I gave you to add work with the original “style.php.” You might have to adjust them because you changed some things. If you change the line-height in #title, then you need to change the margin-top in #topmenu, increasing or decreasing each one together. If you don’t do this, then your top menu will drift away from your header image.

    hi greenshady!

    wow thanks for your fast help!

    i’ll try it after the weekend …
    i’ll post my results here …

    again, thanks!

    sorry with the wrong link … this some kind of a fast search – i didn’t watched at the link 🙂


    IE and layouts = ;-(

    While you are awaiting more tips and try suggestions refer to this site = http://cavemonkey50.com/2005/12/the-ultimate-ie-hack-guide

    I still have problems with three blogs…

    Justin Tadlock


    WordPress God

    Or better yet, you can always design in IE first, then adjust for the other browsers. It’s always worked for me. I think the simple line-height and margin adjustments will work just fine.

    Another great resource on browser compatibility is Position Is Everything: http://www.positioniseverything.net/

    wow thanks alot folks …
    unfortunatly i didn’t have time so far to test the adjustments …
    perhaps i’ll find some time tomorrow to experiment with this issue …


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘page format problem with IE’ is closed to new replies.