Support » Plugin: Auto Amazon Links - Amazon Associates Affiliate Plugin » Page edit mode: Critical error after try to use my old AALB Shortcodes

  • Resolved yoneo12

    (@yoneo12)


    Hello,

    I want to use my old AALB Shortcodes with your nice plugin.

    But I an receiving the following error (when I want to edit a page where the shortcodes can be found):

    WordPress version 5.4
    Current theme: Spacious Child (version 1.6.8.1581855048)
    Current plugin: Amazon Auto Links (version 4.1.0b01)
    PHP version 7.3.15-4+0~20200224.55+debian9~1.gbpbea824

    Error Details
    =============
    An error of type E_ERROR was caused in line 137 of the file /home/www/cleverpedia/wp-content/plugins/amazon-auto-links/include/core/component/unit/_common/_abstract/AmazonAutoLinks_UnitTypeLoader_Base.php. Error message: Uncaught Error: Class ‘AmazonAutoLinks_FormFields_Unit_Template’ not found in /home/www/cleverpedia/wp-content/plugins/amazon-auto-links/include/core/component/unit/_common/_abstract/AmazonAutoLinks_UnitTypeLoader_Base.php:137
    Stack trace:
    #0 /home/www/cleverpedia/wp-includes/class-wp-hook.php(287): AmazonAutoLinks_UnitTypeLoader_Base->replyToGetProtectedMetaKeys(Array)
    #1 /home/www/cleverpedia/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #2 /home/www/cleverpedia/wp-content/plugins/amazon-auto-links/include/core/main/AmazonAutoLinks_MainLoader.php(109): apply_filters(‘aal_filter_cust…’, Array)
    #3 /home/www/cleverpedia/wp-content/plugins/amazon-auto-links/include/core/main/AmazonAutoLinks_MainLoader.php(91): AmazonAutoLinks_MainLoader->_getPluginCustomMetaKeys()
    #4 /home/www/cleverpedia/wp-includes/class-wp-hook.php(287): AmazonAutoLinks_MainLoader->replyToCheckProtectedPostMetaKey(false, ‘spay_price’, ‘post’)
    #5 /home/www/cleverpedia/wp-includes/plugin.php(206): WP_Hook->apply_filters(f

    The shortcodes on the page also don´t be displayed. Have you an Idea, how to fix this? I have made no other settings except the one in your description (other support thread).

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author miunosoft

    (@miunosoft)

    Hi,

    Thanks for the report.

    I’ve uploaded the development version v4.1.0b02 so you should try that.

    Let me know if it makes the error go away.

    Thread Starter yoneo12

    (@yoneo12)

    Thank you so much for the quick help. Yes, the error is now solved.

    But it works only partially. Some shortcodes will be recognized, some not. I don´t know, why this happens. My custom template from AALB won´t be recognized (I have uninstalled before the AALB plugin).

    The following shortcode works:
    [amazon_link asins=’B000UYUGQE’ template=’amzfuer’ store=’cleverpedia04-21′ marketplace=’DE’ link_id=’789a283b-6693-40a1-bcda-981d4de7a17c’]
    And the following shortcode won´t be displayed:
    [amazon_link asins=’B00VE9BU2I’ template=’amzfuer’ store=’cleverpedia04-21′ marketplace=’DE’ link_id=’d41b3446-b1f0-11e8-8043-fff0861fb7e7′]
    (same page https://cleverpedia.de/liste-der-zugelassenen-taschenrechner-in-mecklenburg-vorpommern-gymnasium/).

    Have you an idea, how to fix this?

    Best regards and thanks in advance!

    Plugin Author miunosoft

    (@miunosoft)

    Glad to hear the error went away.

    As for the new issue, can you create a new topic about it as it is different from the initially addressed one? This helps future forum visitors find their information.

    Thank you!

    Thread Starter yoneo12

    (@yoneo12)

    Thank you!

    I have seen, that it now works. I don´t know why, maybe a cron wasn´t done with work.

    Nice plugin!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Page edit mode: Critical error after try to use my old AALB Shortcodes’ is closed to new replies.