Support » Fixing WordPress » Page Edit and Theme Customization not working…

  • Resolved somethingelse

    (@somethingelse)



    ok – this one is a total mystery –
    since yesterday – when no changes were made to the website – we have been unable to edit PAGES, and unable to use the “Customization” in appearance.

    yes we have turned off all plugins
    yes we have reinstalled wordpress
    yes we have switched to default theme
    yes we have renamed htaccess and let it generate a new one

    none of those solutions have worked.
    i currently have a maintenance mode page up, and no other plugins except wordfence active,
    and have it set to twenty-sixteen…

    on PAGE EDIT screen i get white on white text, no tool bar, and switching between text & visual doesn’t do anything (tho if i hightlight the text that is on the page i can see that it is indeed switching) – also don’t get most of the metaboxes – just the publish box, and the heading for “page attributes” but no content in that one.

    on Customize Appearance i just get a 500 error.

    Everything else SEEMS to work just fine. I can edit POSTS with no problem…
    plugin settings seem to be editable.

    Originally i couldn’t even access the PAGES list… and narrowed that down to Jetpack and Learnpress, but still couldn’t get the editing window corrected…

    i’m at the end of my sleuthing skills.
    would be very very grateful for some sherlock assistance at this point.

    • This topic was modified 1 year, 10 months ago by  somethingelse. Reason: added info
Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    Also try:
    – Go to Users->Your Profile. Make sure that the box marked “Disable the visual editor when writing” at the top of the screen is not checked. If it is checked, then uncheck it and scroll down to the bottom of the page and click the “Update Profile” button to save your settings.
    – If that setting is correct, your browser can help you identify JavaScript issues or conflicts. Do you have any Javascript errors in the console when looking at the editor page? This article can assist you in doing that diagnosis.
    – If you use any caching systems, like Cloudflare, clear those caches.
    – Check that the file permissions of all the PHP files are set correct (i.e., 644).
    – Specifically check files like /wp-includes/js/tinymce/wp-tinymce.php and such.
    – If the permissions are incorrect, then some servers running security code like suhosin won’t allow those files to run.

    ok.. thanks for the quick response…

    have checked all those things…
    – disable is NOT checked
    – unless i’m looking in the wrong place i do not see any console errors – checked both firefox & chrome (note, the instructions on this page seem a bit out of date and are all mac screenshots, so maybe i didn’t find the right thing… in both chrome & ff i went to developer tools (i use inspect all day) and could not find anything specifically labelled “error console”… but in CONSOLE both show just
    JQMIGRATE: Migrate is installed with logging active, version 1.4.1
    – i do not use any caching like cloudflare, tho i did double check because we had in the past
    – and all my plugins are still deactivated, anyway
    – checked permissions on all core files, all php’s are 0644

    still no joy…
    here’s a screenshot https://snag.gy/4Nl6rO.jpg of what i’m looking at.

    and without the console visible – https://snag.gy/XQoaGj.jpg

    that’s a PAGE edit… but here’s a POST edit
    https://snag.gy/Qr3vMz.jpg

    oh and i turned on debug in wp-config and the only difference now is that on Appearance>Customize i get a white blank screen, no 500 error
    so that’s something!

    it makes NO SENSE – they use the same editor!
    i’m sure it’s gotta be something simple & small that i’m gapping on…

    • This reply was modified 1 year, 10 months ago by  somethingelse.

    could not find a solution…
    restored a database backup… all is well.

    seems to be caused by LearnPress most recent update, from everything i can tell.

    Moderator t-p

    (@t-p)

    Glad to know it 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Page Edit and Theme Customization not working…’ is closed to new replies.