WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] page doesn't display correct only for category posts (category.php)

[Resolved] page doesn't display correct only for category posts (category.php)

  • Hello,
    I have a problem when diplaying web pages which contain posts for a certain category, i.e. when category.php is used.
    A blank line appears above a page layout (in Chrome and Firefox);
    a blank line appears above the page layout and navigation menu is unorganized (in IE).
    The problem doesn’t appear when displaying a single post or a page (single.php; page.php).
    The example page when category.php is used (error appears):
    http://www.lectoriumrosicrucianum.hr/category/knjige/ ,
    the example page for single post or page (no error):
    http://www.lectoriumrosicrucianum.hr/o-skoli/skola/ .

    An advice is very appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The DOCTYPE is missing from your category pages. Insert that back into the template and most, if not all, the issues you mentioned should clear up.

    Thank you.
    It is there, in the source code for category pages and others. DOCTYPE is included in header.php file.
    I am not sure, but it is possible the problem appeared after WP had been upgraded to 3.4.2.

    Some theme files required optimization. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] page doesn't display correct only for category posts (category.php)’ is closed to new replies.