WordPress.org

Forums

Quark
[resolved] page customize.php not working properly (6 posts)

  1. inavran
    Member
    Posted 1 year ago #

    Hi,

    I recently downloaded and installed quark (so i am on the latest version 1.2.9)

    I am getting this error when i click customise in the wp-admin section

    <b>Warning</b>: Invalid argument supplied for foreach() in <b>/home/webuser/public_html/wp-admin/custom-header.php</b> on line <b>1248</b>

    <b>Warning</b>: array_merge() [function.array-merge]: Argument #2 is not an array in <b>/home/webuser/public_html/wp-admin/custom-header.php</b> on line <b>1268</b>

    <b>Warning</b>: Invalid argument supplied for foreach() in <b>/home/webuser/public_html/wp-admin/custom-header.php</b> on line <b>1248</b>

    <b>Warning</b>: array_merge() [function.array-merge]: Argument #2 is not an array in <b>/home/webuser/public_html/wp-admin/custom-header.php</b> on line <b>1268</b>
    <!DOCTYPE html>

  2. inavran
    Member
    Posted 1 year ago #

    The above by the way is obviously a copy/paste of the source code.

    This appears above the <!doctype html>.

    This does also happen on another wordpress site i have (where i tested your theme), but on that site, it error's then continutes to load the "quark" logo and header, then the rest of the page.

    On the website above, it just halts the webpage.

    Thanks

  3. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    Hi,

    It appears that this is a bug that has been introduced within WordPress when a theme has defined a default image for custom header support.

    You can read more about the issue on WordPress Trac...
    https://core.trac.wordpress.org/ticket/27850

    No doubt there will be a fix released for it soon.

  4. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    This issue will be fixed in 3.9.1 which will be released soon. See this post for the list of issues fixed in WP 3.9.1
    https://core.trac.wordpress.org/query?status=closed&milestone=3.9.1&group=component

  5. ahortin
    Member
    Theme Author

    Posted 1 year ago #

    This issue has been resolved with the latest WordPress 3.9.1 release.

  6. tazo todua
    Member
    Posted 2 months ago #

    On HOMEPAGE, do you use redirection? If so, see the solution: https://core.trac.wordpress.org/ticket/31641

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic