Support » Plugin: Newsletter » Page created by request_to_antibot_form fails when not logged in

  • Resolved designextreme

    (@designextreme)


    Hello!

    I am experiencing an issue with Chrome and Safari users when attempting to verify their subscription using the (very brief) redirecting page created by the method: request_to_antibot_form. It does work with Firefox.

    I have checked the source code before it redirect to the home page but fails with a generic error page and the message:

    ERROR: Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.

    The redirection page is all the output code from this method…

    <!DOCTYPE html>
    <html><head><style type="text/css"> ... </style></head><body><form method="post" action="https://anotherwebsite.com/" id="form"><div style="width: 1px; height: 1px; overflow: hidden"><input type="hidden" name="na" value="c"><input type="hidden" name="nk" value="123-abcdef123abc"><input type="hidden" name="ts" value="123123123123123"></div><noscript><input type="submit" value="Confirm"></noscript></form><script>document.getElementById("form").action="https://thewebsite.com/";document.getElementById("form").submit();</script></body></html>

    As far as I can tell, there are no conflicting plugins or any warnings/errors elsewhere. I have enabled WP_DEBUG, but there are no clues as to the exact issue here.

    Thanks for your time!

    • This topic was modified 3 months, 2 weeks ago by designextreme. Reason: Firefox
    • This topic was modified 3 months, 2 weeks ago by James Huff. Reason: title changed as requested
Viewing 13 replies - 1 through 13 (of 13 total)
Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.