WordPress.org

Forums

Page content displayed twice after WP update (2 posts)

  1. Pipoloco
    Member
    Posted 1 year ago #

    Hi updated wordpress on a custom theme and pages content is now displayed twice.

    here is the template php

    <?php
    /**
     * Template Name: Une page 'domaine'
     *
     * @package WordPress
     * @subpackage Starkers
     * @since Starkers 3.0
     */
    
    get_header(); ?>
    
    <script type="text/javascript">
    
      var inTrans = false;
    
      $(window).load(function() {
        var $block = $('.blue_block');
        var $doc = $(document);
    
        var resize2 = function() {
          $block.css('height', $doc.height() - 250);
        };
    
        $(window).resize(resize2);
    
        resize2();
      });
    </script>
    
    <!--[if IE]>
    <style>
      #side_bar {
        behavior: url(<?php echo bloginfo('template_url') ?>/pie/PIE.php);
        zoom: 1;
      }
    
      #side_bar section {
        behavior: url(<?php echo bloginfo('template_url') ?>/pie/PIE.php);
        zoom: 1;
      }
    </style>
    
    <![endif]-->
    
    <?php if ( have_posts() ) while ( have_posts() ) : the_post(); ?>
    
      <article class="grid_7 alpha blue_block practice">
        <div class="content">
          <?php if (function_exists('dimox_breadcrumbs')) dimox_breadcrumbs(); ?>
          <h3><?php echo the_title() ?></h3>
    
          <?php the_content(); ?>
    
          <ul class="subpages">
            <?php
              query_posts(array('post_parent' => $post->ID, 'post_type' => 'page', 'orderby' => 'menu_order', 'order' => 'ASC'));
              while (have_posts()) : the_post();
            ?>
              <li>
                <div class="thumbnail"><a href="<?php echo post_permalink() ?>" class=""><?php if ( has_post_thumbnail() ) { the_post_thumbnail("thumbnail"); } ?></a></div>
                <div class="content">
                  <h5><a href="<?php echo post_permalink() ?>" class="">&raquo; <?php echo the_title() ?></a></h5>
                </div>
              </li>
            <?php endwhile; wp_reset_query(); ?>
          </ul>
    
          <div class="clear">&nbsp;</div>
        </div>
      </article>
      <?php endwhile; ?>
    
      <?php get_sidebar(); ?>
    
    <?php get_footer(); ?>

    anybody as an idea how to solve this issue?

    Thanks

  2. Pipoloco
    Member
    Posted 1 year ago #

    you can see the issue live here : girus

Topic Closed

This topic has been closed to new replies.

About this Topic