Support » Fixing WordPress » page comment not active

  • sunddenly somehow i cant see the comment box in the Page. it seems it was deactivated ..how can i get it back?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Have you disabled comments for that particular page when you created it? Check in the Manage Pages administration page/menu.

    no.i really made sure its not disabled 🙁

    if i use the default theme ..thats when its not showing up..am i the only one having such problem?

    46664, can you confirm that your page template has the following piece of code after the entry loop:


    <?php comments_template(); ?>

    in page template? none.


    <?php the_content('<p class="serif">Read the rest of this page &raquo;</p>'); ?>

    <?php link_pages('<p><b>Pages:</b> ', '</p>', 'number'); ?>

    <?php comments_template(); ?>

    your page template should have the above..

    add that comments_template tag below your stuff and that should sort it… lemme know

    its working now..is it safe to put that code in the other theme?

    should be..

    the comments_template is essentially the php include for the reply form that you see after your blog entries.. all that happens when you add that is that your page pulls in that comments template..

    fool proof..

    here’s an example. thats a page that has the comments enabled…

    thanks a lot… !!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘page comment not active’ is closed to new replies.