WordPress.org

Forums

Page cannot be found when clicking confirmation link (3 posts)

  1. doodleink
    Member
    Posted 3 years ago #

    Hello all,

    I am new to WordPress and have just done the install. I have configured it to use the multisite/network option.I have attempted to test the "Add User" option. The creation of the user goes just fine, but when I attempt to add the user to the existing site (there is only one at present time), the user gets a confirmation email. The link for the user to confirm though produces a 404 error stating this:
    The requested URL /newbloguser/eccbc/ was not found on this server.

    The error is correct as this directory does not exist, but if that is the case where should it be directing the user and how/where do I modify the code to do this?

    Thanks in advance for any assistance.

    Russ

  2. Tara
    Volunteer Moderator
    Posted 2 years ago #

    try:

    -deactivating ALL plugins temporarily to narrow down the problem. If the problem goes away, activate them individually (one-by-one) to find the problematic plugin.

    -switching to the unedited default theme (twentyeleven) for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

  3. doodleink
    Member
    Posted 2 years ago #

    Thanks for the response. Here is the current setup:
    Wordpress 3.3.2 using the default theme.
    Wordpress was installed to allow for the multisite blogging using the described method to enable the Network Admin dashboard.
    Currently the only plugin in use is Configure SMTP by Scott Riley http://coffee2code.com/wp-plugins/configure-smtp/ as I do not have an email server on this box nor one available to me.

    The steps I have determined to cause this are:
    1. Log into the site as the global administrator.
    2. Select the Network Admin Dashboard then Users > Add New.
    3. After the user is created, select the site I would like to add the user to (My Sites > site name)
    4. Select Users > Add New. Enter in the information for "Add Existing User" and select the role. Leave the checkbox for "Add User without send them a confirmation email" unchecked. Click "Add existing user."
    5. When the confirmation email arrives the body states:

    Hi,

    You've been invited to join 'Enchanted Life' at
    http://www.enchantedlife.me with the role of editor.

    Please click the following link to confirm the invite:
    http://www.enchantedlife.me/newbloguser/eccbc/

    When clicking the link supplied for confirmation this is when I get the 404 error. I'm not sure if this path should exist or not, but I know if it not shown in my directory.

    If you attempt to add the user minus the confirmation through the site or if you addd the user to the site through the Network Admin Dashboard (which also does not send a confirmation) the user gets added.

    I know the easiest method would be to just eliminate the step of requesting a confirmation, but I was just curious as to why it is doing this.

    Thanks again.

    Russ

Topic Closed

This topic has been closed to new replies.

About this Topic