Support » Plugin: WP Cloudflare Super Page Cache » Page caching seems not working for both dynamic and static pages.

  • Resolved robisan

    (@robisan)


    Hi guys,

    While I try to test the cache, I’m getting the following error msg.

    Page caching seems not working for both dynamic and static pages.
    
    Error on dynamic page (https://tractarimvbcluj.ro): Cache status: BYPASS - Cloudflare has been instructed to not cache this asset. It has been served directly from the origin.
    
    Error on static resource (https://tractarimvbcluj.ro/wp-content/plugins/wp-cloudflare-page-cache/assets/testcache.html): Unable to find the Cache-Control response header.
    
    Please check if the page caching is working by yourself by surfing the website in incognito mode 'cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT, the page caching is working well.
    Close

    https://i.imgur.com/HIEvzRp.png
    I’ve checked the headers but I was unable to find the cf-cache-status: HIT
    https://i.imgur.com/Ptr8exw.png

    Also I’ve disabled all caching plugins, removed the page rules. Any help would be highly appreciated 🙂

    Best regards,
    Robi

    • This topic was modified 11 months, 3 weeks ago by robisan.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello:

    I have the same error.
    cf-cache-status is BYPASS for dynamic pages and HIT for static resources.

    In the debug.log the communication with the API seems to be correct.

    Regards,
    Guillermo

    • This reply was modified 11 months, 3 weeks ago by gozalbes.
    • This reply was modified 11 months, 3 weeks ago by gozalbes.
    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @robisan ,
    sometimes the test fails so the plugin asks you to test by yourself. The page caching is working well on your website:

    https://imgur.com/SWBkrPV

    @gozalbes I need to know more details. Give me the link to your website so I can check.

    Hi @salvatorefresta

    My website is https://www.cadistasfinos.com

    The error when test the cache the is:
    “Page caching seems not working for both dynamic and static pages.
    Error on dynamic page (https://www.cadistasfinos.com): Cache status: BYPASS – Cloudflare has been instructed to not cache this asset. It has been served directly from the origin.
    Error on static resource (https://www.cadistasfinos.com/wp-content/plugins/wp-cloudflare-page-cache/assets/testcache.html): Unable to find the Cache-Control response header.

    Please check if the page caching is working by yourself by surfing the website in incognito mode ’cause sometimes Cloudflare bypass the cache for cURL requests. Reload a page two or three times. If you see the response header cf-cache-status: HIT, the page caching is working well.”

    The header in main page is: cf-cache-status: BYPASS
    However in the static elements (js,css,images,testcache.html) is: cf-cache-status: HIT

    Where is the problem?

    Hello. Not trying to pile on here, but rather just to let you know more people are experiencing this.

    I’ve manually verified caching is working, so I’ll just include steps on how to check that, in the guide I’m finishing up.

    Thanks!

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @robisan,
    As @salvatorefresta has confirmed that the page caching is working perfectly for your website. Sometimes the Test Cache does not show the correct headers as sometime Cloudflare sends wrong headers when accessed via cURL compared to an actual browser. If you check the log of the plugin you will see the headers received by the plugin when you clicked on Test Cache and definitely there is no cf-cache-status: HIT.
    But as you can see in the screenshot here: https://i.imgur.com/GYfZH8b.png the page caching is working perfectly on your website.

    In your case @gozalbes, if you look closely to your headers, as I can see your page is loading a lot of custom cookies when it loads: https://i.imgur.com/rsOx99V.png and each time Cloudflare sees any custom cookies in a page it thinks that those cookies might be used to showing dynamic content on that page based on those cookie data. Hence CF doesn’t cache those pages. So, you can either remove the plugin which are adding those extra cookies or you can enable the “Stripe Response Cookies” option and see how that works for you.

    In answer to your question @wpturnedup, we have recently added a review video of this plugin (since v4.3.8) in the description section. So, if you now check the plugin description, you will see the video and in that video, it has been clearly shown how to check the response headers. I hope that will help everyone and exactly what you are asking for.

    Yep, as mentioned, I already knew how to check it, but thanks! ; )

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @wpturnedup,
    Yes, I know that you know as you have already mentioned but that video is supposed to help people who don’t know how to do that. What do you think?

    Thread Starter robisan

    (@robisan)

    Hi @isaumya @salvatorefresta , thanks for looking into it, really appreciate it!
    Weird but now indeed I can see the header cf-cache-status: HIT, maybe it just took a while to properly update or I’ve just missed it lol.

    Thanks for the confirmation and keep up the good work.

    Regards,
    Robi

    Sure. Would just state that in general. 😉 No biggie. Thanks again.

    • This reply was modified 11 months, 3 weeks ago by WP Turned UP.

    Hi @salvatorefresta
    Thank you very match for your support.
    I had a plugin installed (Yoast SEO) that generated strange cookies. I have deactivated the plugin, I have activated it again and it no longer generates them.
    Now the Cloudfare page cache works correctly!.

    Hi @salvatorefresta
    I am having this same problem. Two sites verified perfectly, and I noticed a good result with loading times. But a new one I am creating will not test properly. I tried opening a few times on another browser and get “cf-cache-status is BYPASS” when I check the headers. The site is crystalmesaconservancy.com. Any thoughts on this one?

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @dwalker108,
    Your case is exactly like @gozalbes. The reason you are seeing CF Cache Bypass is that your page loads custom cookie. Each time Cloudflare sees any custom cookies in a page it thinks that those cookies might be used to showing dynamic content on that page based on those cookie data. Hence CF doesn’t cache those pages. So, you can either remove the plugin which are adding those extra cookies or you can enable the “Stripe Response Cookies” option and see how that works for you.
    Screenshot: https://i.imgur.com/J0YZJte.png
    Hope this helps. 🙂

    Hi @isaumya
    That worked. THanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Page caching seems not working for both dynamic and static pages.’ is closed to new replies.