Support » Plugin: Super Page Cache for Cloudflare » Page caching is working for static page but seems not working for dynamic pages.

  • Resolved northwst

    (@northwst)


    Hello,

    Your plugin sounds great, thank you for your efforts.

    When I set-it up, I get this error:

    Page caching is working for static page but seems not working for dynamic pages.

    I tried both API token/key and that didn’t work. Is there a fix you can recommend?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @northwst,
    As I can see the page caching is working perfectly on your website. Please note that the “Test Cache” button does not always provide the most accurate result and hence the best way is to check the response header of your website (checking it as a normal user without being logged in).

    Screenshot:
    https://i.imgur.com/yJF87EZ.png
    https://i.imgur.com/OJWSu2S.png

    But that being said, there is a small issue I can see in your website. Something (either some plugin or server config) is adding cache-control: max-age=600 header to the HTML type responses. You need to figure out what is adding it and you have to get rid of it. Only this plugin will handle the cache-control header for the first HTML type request. Nothing else.

    Screenshot: https://i.imgur.com/KBpAPyq.png

    If you don’t have any idea about this, talk to your host about it. Ask them what is adding it and remove it.

    Thread Starter northwst

    (@northwst)

    Hey @isaumya

    Thank you so much for your prompt support! I think it took a little time for it to be fully cached, I was experimenting and visiting the same page using incognito but I was just not getting HIT. Test Cache still gives the same error but now we know it’s actually working fine.

    Thanks for the additional note – I previously had other caching plugins installed (deleted) – so maybe it’s one of them. I will need to dig a bit deeper.

    Just one more question, if you don’t mind. Now the page is fully cached on CF, it’s still loading fairly slowly (5.6s on GTMetrix). It’s hosted on DH shared, so it won’t be the fastest server by any means, but with CF I thought it would be a bit better than that, given the page size is 0.96mb. Is this normal behaviour? Or is there anything else I should be doing?

    I’m not sure if the images are served from CF, or if you would recommend an additional plugin to serve images from CF too.

    Thank you

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @northwst,
    In the GTMetrix the 5.4s you see is the largest contentful paint which is causing by your big slider. Check this report for another page from your website: https://gtmetrix.com/reports/beautycornerm33.co.uk/yO04mtgx/

    But do figure out what’s adding the cache-control: max-age=600 and remove it.

    Thread Starter northwst

    (@northwst)

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Page caching is working for static page but seems not working for dynamic pages.’ is closed to new replies.