W3 Total Cache
[resolved] [closed] Page Cache URL rewriting is not working (119 posts)

  1. pull-start
    Posted 5 years ago #

    I tried altering those lines of .htaccess, and it didn't solve the problem. Enabled "Minify" and got a totally un-styled website, with and without "Rewrite URL structure" enabled.

  2. WebEndev
    Posted 5 years ago #

    I was looking at Frederick Townes (plugin authors) Twitter, and am starting to think that he might think that version 9.2.1 has fixed this 'no styling' issue.
    His comments are hours old, and not indicating he is working on anothr release.
    There is definitely still a problem
    I will not be progressing beyond version 9.1.3 on any of my sites, or my clients sites until another release.
    Great plugin though. My hat's off to Frederick and his dedication!

  3. Fixed for me in

    URL Rewriting - It works!

    Lightbox - Mostly. There's a weird issue I've sent a screenshot to him. Low priority IMO.

    Minify - I had to switch to manual and add in the files one at a time, but frankly, that's what I had to do on anyway, so not a difference to me, except I had to re-enter everything. Then again, doing that was probably a good idea anyway.

  4. pull-start
    Posted 5 years ago #

    Ipstenu - did it remember your old Minify settings? I haven't re-entered all of my CSS and JS that way, because the plugin seemed to remember the old (working) settings from 0.9.1.

    But maybe that will be the ticket. I'll try that.

  5. pull-start
    Posted 5 years ago #

    Still not working. Here's a clue:
    When I add my stylesheet or JS file to Minify settings manually, then view the page source (in a different browser, not logged in) I see the w3tc-generated file. In my case, it's called "http://www.pull-start.com/wp-content/w3tc/min/b16b5/default.include-footer.2909374324.js"

    But if I try to view that file in the browser, I get a blank page with just this text: "Bad file param format."

    Same thing with CSS. Seems like something's getting screwed up by the Minify process. The CSS and JS files have not changed at all from the versions that were working before the update.

  6. Ipstenu - did it remember your old Minify settings?

    Nope, but I don't think that was W3TC's fault, given that I uninstalled and wiped the DB during my tests.

    But if I try to view that file in the browser, I get a blank page with just this text: "Bad file param format."

    Hey! That's progress :D

    What's your wp-content/w3tc/min/.htaccess look like?

  7. pull-start
    Posted 5 years ago #

    This is it:

    [Code moderated as per the Forum Rules. Please use the pastebin]

  8. pull-start
    Posted 5 years ago #

    from another thread:

    when minified, JS and CSS return "Bad file param format"

    With FTP I had a look into the minify directory

    There are two files:

    default.include.css.id containing i:615365546;
    default.include-body.js.id containing i:2138336412;

    nothing more..

    In the last good version there were six files:

    default.include.615365546.css 21kByte
    default.include.615365546.css.gzip 5kByte
    default.include.css.id containing 615365546
    default.include-body.591478768.js 113kByte
    default.include-body.591478768.js.gzip 45kByte
    default.include-body.js.id containing 591478768

    So the combined/gzipped versions were never produced. Hmm.

  9. pull-start
    Posted 5 years ago #

    Modified above post. Here is my .htaccess in full.

  10. Interesting... I would rename that file old.htaccess and let W3TC generate a new one.

  11. pull-start
    Posted 5 years ago #

    After doing as you suggested, the new .htaccess now has the lines mentioned in the other post. In addition, two .js files and a directory ("b16b5") showed up in the min directory.

    (The old.htaccess file disappeared completely.)

  12. And the CSS on http://www.pull-start.com/ looks fine to me so... yay? Are we working now?

  13. pull-start
    Posted 5 years ago #

    I thought so, but... No.

    I noticed that the Jquery slider in my page wasn't loading images. And I had CSS minification turned off. When I turned that back on, I got the same un-styled page again. So now I have minification off again.

    And I still get "Bad file param format" if I try to view either CSS or JS files generated by w3tc.

    Could this have something to do with the fact that I don't use any CDN at all? (Never really known how/whether to set it up for the site, so I just leave it disabled.)

  14. No, I don't have CDN on either.

    It's got to be a conflict with your css/js and minification. I BET if you turn on Manual minification and add in files one at a time, you'll find which one breaks things.

    (I'm not saying Minification ain't broke, I'm just saying we don't know what PART is broke till we can narrow down what CSS or JS files are killing you. Yes, it's work. Next person who bitches that one to me gets no more help ;) )

  15. pull-start
    Posted 5 years ago #

    Thanks for the help. Not bitching, I swear!

    I'm baffled though. It doesn't seem to matter which JS or CSS file I add to Minify settings. Even if it's just the Google-hosted JQuery library, I still get the "Bad param file format" if I try to view the w3tc-generated JS file. It's got to be something with the new files created by Minify, no? Or maybe it's that "JS minifier" setting... Should I switch from default to YUI and see if that helps? I don't know what the difference is...

    Anyway, I tried just one CSS file at a time, then one JS file at a time. All of them fail to appear properly after minification. Obviously, some of them are more critical than others (like the main style.css), so the effect isn't always obvious at first glance.

  16. toyNN
    Posted 5 years ago #

    Can't add much here other than I'm seeing similar to @pull-start - the minified css and js files don't appear to be created properly.

    I've tried numerous setting changes to minify but result seems to be same. The /wp-content/w3tc/min folder is populated with css.id and js.id files that only contain a value like "i:2066067813;".

    My page source is pointing to,
    ..."/min/576ad/default.include.2066067813.css" which doesn't exist.

    The mod_rewrite rules don't appear to me to have anything to do with this.

  17. SlowClicksDotCom
    Posted 5 years ago #

    I'm just dropping by again in this thread to say that I'm experiencing the same issues as toyNN & pull-start are. It seems that even after the fix, any form of minification, whether manual or auto, one-by-one modifications, with or without URL rewriting, just does not work. I have minified turned off on Insfired.com until we get a real fix.

  18. simbian
    Posted 5 years ago #

    @vitalichka: i have done it, set the minify to manual, then specified css but still the frontend appear raw like without css, i also unchecked "Rewrite URL structure".

    I had to disable the minify by now waiting another solution/fix

  19. yolaws
    Posted 5 years ago #

    Sorry for my English!
    I am using "W3TC" and when the "Minify mode" is activated to "Auto" the pages generated are broken because the "W3TC" changes from http to https on some urls, but my server does not support ssl, cached pages can not access the files in / wp-content/w3tc/min using https

    Fragment of the source code of the cached page:

    <html xmlns="http://www.w3.org/1999/xhtml">
    <head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" type="text/css" href="https://www.xxxx.com/wp-content/w3tc/min/822439d9a654d52d37d12046d4f8ffd8.1930919287.css" media="all" />
    <script src="https://www.xxxx.com/wp-content/w3tc/min/0f697536ac244db36761f59d70d001d6.2122574435.js"></script>

    How can i fix this?

  20. AstroGremlin
    Posted 5 years ago #

    I lost all my theme styles, and had veerrry slow loading. I turned off all the W3 checks boxes and checked them on one by one. It looks as though the Content Delivery Netowrk (CDN) was the problem. In any case, I now have everything but CDN turned on, and theme styling and performance returned. In fact I checked performance on a evaluator site and speed improved.

  21. vitalichka
    Posted 5 years ago #

    Just dropping by, same thing happening, things are basically broken if minify is used and if URL rewritting is on.

    Sad to hear the plugin author thinks it's working fine.

    Munman do you have the twitter id for Frederick? I think it might be a good idea to post this URL to him, maybe then he'll consider revising.


  22. He knows about it and is working on it.

    If you want to get in touch with him, I'd use the form on yourdomain.com/wp-admin/admin.php?page=w3tc_support

  23. vitalichka
    Posted 5 years ago #

    Thanks for the update. Glad to know he's working on a resolution.

  24. vitalichka
    Posted 5 years ago #

    So I just went to 9.1.3, installed it, when I tried to activate it, it crashed the site. Now all I see is a 500 Internal Server Error.

    Could someone please help me out with this.

    Turns out the latest version was conflicting with Advertising Manager

    I know munman was saying that the older version of W3TC was stable, but now looks like the site is down.

    If someone has some input, it would be greatly appreciated.

    Thanks again

  25. vitalichka
    Posted 5 years ago #

    Ok so looks like I got it.
    I do have one little questions though.

    In the general tab it says "Deselect this option to disable all caching functionality."

    And although I know many have asked and wondered about the non-intuitive UI wording, this is not about that.

    When I check the box and save, it reloads and the box is again unchecked (deselected). So with that said how would one go about making sure it stays selected so that caching functionality is enabled?

    Thank you all

    *** Update ***

    I should also probably mentioned that even when I disable CDN from the general tab as it is not set up for me, and I save the changes, and then empty the cache, it still re-enables it for me and pops up messages at the top saying

    Make sure to and upload your , , , , files to the CDN to ensure proper operation.

    Any ideas as to going around this?

    Thanks again and looking forward to some help on this one.

    ***Update 2***

    So I think I might have figured this out.

    It seems that when you enable CDN but not configure it, it will pop up messages asking you to configure the settings but the Deselect this option to disable all caching functionality. checkbox will stay checked.

    However if you disable CDN from the general tab and save the changes, the Deselect this option to disable all caching functionality. check box deselects itself and will not stay selected.

  26. vitalichka
    Posted 5 years ago #

    Looks like I may have misunderstood the checkbox text. However I should mention that an error still comes up stating that the proper directives were not found for fancy URLs. I tried adding the code to the .htaccess file but all that does is result in a 500 error.

    So for now I have disabled Rewrite URL structure in minify and that seems to avoid the issue however I understand this is not a solution. There is certainly a good chance I am misunderstanding something.

    I should mention that I am no longer able to find the .htaccess file for W3TC and only have the root domain .htaccess file.

    Or..... maybe I just need to catch some zzzzzs.

  27. vitalichka
    Posted 5 years ago #

    Ok this has gotten totally nutty.
    I thought I got everything to work, was about to turn in to bed.
    Went to the site one last time and clicked on a post.
    All posts and pages now lead to a 404.

    Can someone please help me out with this?

    I've reset the .htaccess file, I've disabled the W3TC plugin, now removed it completely, all directories, the W3TC config file, everything, no trace of it.

    All pages still lead to a 404 page. Tried in IE, Firefox, Chrome, and Cell phone. Maybe you guys could give it a try but I think it's pretty much everything is a 404 now. Oddly, the home page loads no problem.

    Salt Lake Examiner


    All fixed.
    W3TC is disabled, will play with it tomorrow.
    And now I have the ugliest .htaccess file which has lots of remnants of W3TC which is no longer on the server.

    Tomorrow, tomorrow.

    Sorry for the constant posts here, I've been trying to be good about editing my posts and adding to them or listing as an update.

  28. WebEndev
    Posted 5 years ago #

    @ vitalichka
    What has worked for me is to disable W3TC, then delete your .htaccess file. Then enable W3TC and it will rebuild your htaccess file correctly.
    Works for me every time... Take it as you will

  29. @vitalichka I had to un-flag you in the spam system.

    PLEASE STOP POSTING MULTIPLE TIMES IN A ROW. It's annoying to everyone, and you ARE tripping the spam tools. Knock it off. Do all your tests, stop, write it all down, THEN, when you're done, post. But 5 posts in the same topic in two hours, with no one in between, is spamming. Well intentioned, but you're spamming.

    At four pages, I'm closing this topic, since no one will be able to sort through it and help anyone.

    vitalichka - Make ONE TOPIC for yourself, with a SUMMARY of what's going on.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic