WordPress.org

Support

Support » Plugins and Hacks » W3 Total Cache » Page Cache – Status = not cached?

Page Cache – Status = not cached?

  • Have the latest version installed, logged out of wordpress with debug more turned on. Still status = not cached??

    Engine: disk (enhanced)
    Cache key: issue/the-tailored-issue/_index.html.gzip
    Caching: enabled
    Status: not cached
    Creation Time: 1.117s
    Header info:
    X-Pingback: http://dev.fashion156.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Content-Type: text/html; charset=UTF-8
    Last-Modified: Mon, 15 Aug 2011 18:34:11 GMT
    Vary: Accept-Encoding, Cookie
    X-Powered-By: W3 Total Cache/0.9.2.3
    Content-Encoding: gzip

    The same output (not cached) on all pages / posts

Viewing 15 replies - 1 through 15 (of 47 total)
  • Same problem for me.i sent a bug report to Frederick Townes. i have been waiting for 2 weeks but he hasn’t replied me yet 🙁

    Yep. I’ve seen customers and clients running into the same thing.

    Sometimes I can get it to show cached content when I clear out my cookies, but other times I’ve seen the same message in view source across different browsers on the same computer. Like ones I’ve never even logged into WordPress from.

    I’ll be interested to see if/when there’s a fix for this, but I’ve been recommending Super Cache in the interim.

    Hmm thats anoying! Guess I shall have to use super cache.
    Thanks for the advice

    Same issue. The cache directory has seen the items generated. I wonder if this is a false message?

    Installing supercache instead of w3t can solve only page caching problem. But w3t support all caching types. So we need to solve this serious issue.
    @squaretwo this is not a false message. i have already tested it by installing a random posts plugin. After each refresh of the page random posts sequence has been changed. it is proof that the page caching of w3t doesn’t work!

    Got the same issue. Partially fixed it by adding trailing slash to the perma links structure.

    Now I have some of mine pages cached, but not all. Weird.

    Regards,

    Happy face. Have some news.

    Found the bugger that was messing with W3TC proper working (in my case). One plugin have this line ‘@ob_start(“ob_gzhandler”);’ and after commenting it the W3TC start to cache all pages.

    It worked in my case, please check and see if there is something similar that is trying to do GZIP compression for the HTML and share you findings.

    Regards,

    Good find CyberOto!
    Which plugin is this? I shall do a grab soon.

    Anything further on this?

    In this closed thread, Frederick states:

    “You can always look on the file system or in the opcode cache control panel to see if objects are being created.”

    Can someone explain this? I’m getting “not cached” status on all pages, posts and index on 3 sites. Would love to know if there’s another way to see if pages are being cached or not.

    I submitted a bug report recently. I see Frederick is doing one of his posting marathons- hope he’ll reply and shed some light on this.

    Plugin Author Frederick Townes

    @fredericktownes

    This is fixed in the development version. Sorry for the trouble.

    Thanks, Frederick. What is the best way to install the development version? Uninstall current version, install development version, upload settings?

    This is fixed in the development version. Sorry for the trouble.

    No, it’s not. Just installed development version 0.9.2.5b, and still getting:

    <!-- W3 Total Cache: Page cache debug info:
    
    Engine:             disk: enhanced
    
    Cache key:          _index.html_gzip
    
    Caching:            enabled
    
    Status:             not cached
    
    Creation Time:      0.323s
    
    Header info:
    
    Set-Cookie:         bb2_screener_=1315863307+108.66.209.1; path=/
    
    X-Pingback:         http://mysite.com/xmlrpc.php
    
    Content-Type:       text/html; charset=UTF-8
    
    Last-Modified:      Mon, 12 Sep 2011 21:35:07 GMT
    
    Vary:               Accept-Encoding, Cookie
    
    Expires:            Mon, 12 Sep 2011 21:38:07 GMT
    
    Pragma:             public
    
    Cache-Control:      public, must-revalidate, proxy-revalidate
    
    Etag:               02bf4a699f1153dcf306c56cd1e02303
    
    X-Powered-By:       W3 Total Cache/0.9.2.5b
    
    Conte
Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘Page Cache – Status = not cached?’ is closed to new replies.
Skip to toolbar