Support » Plugin: MetaSlider » Page Builder in conflict with MetaSlider after a save. Pages and posts are no mo

  • Resolved potoman

    (@potoman)


    HIGH: Page Builder in conflict with MetaSlider after a save. Pages and posts are no more displayed.

    Hello,

    I started using Page Builder last month.

    Everything went well till I was modifying a post with Live Editor.

    When I tried to save my changes, Page Builder took a long time and no pages ans posts initially designed with Page builder are no more displayed.

    After investigating, I found out that there is a conflict between Meta Slider and Page Builder plugins now.

    As a lot of the pages of the site are designed with Page Builder now, and including metaslider slides, such as start and landing pages, it’s a severe issue as the site is no more accessible as designed !

    Thanks for your feedback and for your help !

    Potoman

    I’m using …
    – Page Builder by SiteOrigin – Version 2.9.1
    – MetaSlider – Version Version 3.10.0
    – MetaSlider – Pro Add-on Pack – Version 2.9.2
    – WordPress – Version 4.9.9

    My website
    http://www.potoclips.com

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 33 total)
  • Navigator Console (Firefox)

    OpenGL compositor Initialized Succesfully. Version: 2.1 ATI-1.32.25 Vendor: ATI Technologies Inc. Renderer: AMD Radeon HD 6770M OpenGL Engine FBO Texture Target: TEXTURE_2D
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    [Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 183” data: no]
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    1545305030584 addons.update-checker WARN onUpdateCheckComplete failed to parse update manifest: [Exception… “Update manifest is missing a required addons property.” nsresult: “0x80004005 (NS_ERROR_FAILURE)” location: “JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 121” data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:121 parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:131 onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:313 UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:242
    1545305030650 addons.update-checker WARN onUpdateCheckComplete failed to parse update manifest: [Exception… “Update manifest is missing a required addons property.” nsresult: “0x80004005 (NS_ERROR_FAILURE)” location: “JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 121” data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:121 parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:131 onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:313 UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:242
    1545305030665 addons.update-checker WARN onUpdateCheckComplete failed to parse update manifest: [Exception… “Update manifest is missing a required addons property.” nsresult: “0x80004005 (NS_ERROR_FAILURE)” location: “JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 121” data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:121 parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:131 onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:313 UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:242
    1545305030738 addons.update-checker WARN onUpdateCheckComplete failed to parse update manifest: [Exception… “Update manifest is missing a required addons property.” nsresult: “0x80004005 (NS_ERROR_FAILURE)” location: “JS frame :: resource://gre/modules/addons/AddonUpdateChecker.jsm :: getRequiredProperty :: line 121” data: no] Stack trace: getRequiredProperty()@resource://gre/modules/addons/AddonUpdateChecker.jsm:121 parseJSONManifest()@resource://gre/modules/addons/AddonUpdateChecker.jsm:131 onLoad()@resource://gre/modules/addons/AddonUpdateChecker.jsm:313 UpdateParser/<()@resource://gre/modules/addons/AddonUpdateChecker.jsm:242
    JQMIGRATE: Migrate is installed, version 1.4.1 autoptimize_7b42c697d10d23466bc859fb9184a495.js:2:542
    Ce site semble utiliser un effet de positionnement lié au défilement. Cet effet pourrait ne pas fonctionner correctement avec le défilement asynchrone. Consultez https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects pour obtenir davantage de détails ou discuter des outils et des fonctionnalités liés. f-a-q-frequently-asked-questions-plier-deplier
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    about:devtools-toolbox : Unable to run script because scripts are blocked internally.

    Slideshow Theme Reactivated
    [Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 183” data: no]

    Slideshow Theme Re Deactivated
    onStopRequest resource:///modules/FaviconLoader.jsm:183:16 InterpretGeneratorResume self-hosted:1255:8 next self-hosted:1210:9
    [Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 183” data: no]
    [Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 183” data: no]
    InvalidStateError: A mutation operation was attempted on a database that did not allow mutations.
    [Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 183” data: no]

    STEP 2

    Try to use an image slide instead of the “Post feed” slide. See if that works.

    After creating a new image feed slider and adding it (replacing the previous one) in a test page with only one slide…

    Effects (or not)

    – in PageBuilder (Preview): Preview available – OK
    – in Potoclips.com: Page displayed, slide displayed (no more blank page) – OK

    Then I configured a slideshow theme for this new slider

    – in PageBuilder (Preview): Preview available – OK
    – in Potoclips.com: Page displayed, slide displayed (no more blank page) – OK

    Then I re deactivated Add-on Pro 2.12.0 – Meta Slider

    – in PageBuilder (Preview): Preview available – OK
    – in Potoclips.com: Page displayed, slide displayed (no more blank page) – OK

    New slide with image feed

    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope
    page_performance.js:18
    o moz-extension://c34d4630-21bf-2b49-87d8-4e47f5b3eb87/dist/page_performance.js:18:17571
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18
    JQMIGRATE: Migrate is installed, version 1.4.1 autoptimize_7b42c697d10d23466bc859fb9184a495.js:2:542
    Ce site semble utiliser un effet de positionnement lié au défilement. Cet effet pourrait ne pas fonctionner correctement avec le défilement asynchrone. Consultez https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects pour obtenir davantage de détails ou discuter des outils et des fonctionnalités liés. f-a-q-frequently-asked-questions-plier-deplier
    JQMIGRATE: Migrate is installed, version 1.4.1 autoptimize_928a083ca0f3b6ed4d743ba5e56092d1.js:2:542
    Promise rejected after context unloaded: Promised response from onMessage listener went out of scope page_performance.js:18
    Unchecked lastError value: Error: Promised response from onMessage listener went out of scope page_performance.js:18

    FYI, Site updated to WordPress 5.0.2.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @potoman,

    Can you state in which circumstance it worked and what specific addition/change breaks it?

    For example, It seems that it works with image slides. So does it only work with image slides? i.e. all other slides break it? or does only a specific slide type (yt, vimeo, layer) break it?

    Is this a true statement? “It works with image slides, but when I change to post feed slide then it breaks. All other changes have no effect”

    Are you able to check your server error log file for any information?

    Thanks

    Hi kbatdorf (@kbat82),

    I think I probably isolated the issue or the issue factor.

    To do so, I recreated one of my standard slider, step by step.

    Metaslider – WordPress 5.0.2 – Add-on Pro 2.12.0 – Meta Slider Pro Activated

    1 – I first created a new slider and keep it basic and standard.

    Type: R.Slides
    Width:700px
    Height:500px
    Effect:Fade
    Arrows: V
    Navigation: Dots

    Caption template
    {title}
    – Post types
    Posts

    Taxonomies
    – 1 (Category with 13 corresponding posts)

    Display settings
    – Slide link: Post
    – Order By: Publish Date – DESC
    – Posts Limit: 3
    – Preserve New Lines: V

    No Slideshow Theme selected

    Effects (or not)

    – in PageBuilder (Preview): Preview available – OK
    – in Potoclips.com: Page displayed, slide displayed – OK

    2 – I selected a Slideshow Theme

    Effects (or not)

    – in PageBuilder (Preview): Preview available – Still OK
    – in Potoclips.com: Page displayed, slide displayed – Still OK

    3 – I selected – Order By: Random – DESC

    Effects (or not)

    – in PageBuilder (Preview): Preview available – Still OK
    – in Potoclips.com: Page displayed, slide displayed – Still OK

    4 – I selected – – Posts Limit: 12

    Effects (or not)

    – in PageBuilder (Preview): No Preview available – KO
    – in Potoclips.com: No Page displayed, No slide displayed – KO

    5 – I selected back – – Posts Limit: 3

    Effects (or not)

    – in PageBuilder (Preview): Preview available – OK Again
    – in Potoclips.com: Page displayed, slide displayed – OK Again

    Posts Limit: 6 – OK
    Posts Limit: 8 – OK
    Posts Limit: 9 – KO

    So it seems that the Posts Limit is the issue.
    Keep me posted,
    Regards,
    Potoman

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @potoman,

    It’s good that the issue was narrowed down! 🙂

    So the page builder breaks with the 9th post? Does the “preview” button within MetaSlider work?

    What if you add a new post so post #9 becomes post #10? Then is a post limit of 9 okay?

    potoman

    (@potoman)

    Hi kbatdorf (@kbat82),

    Ny comments below:

    So the page builder breaks with the 9th post?
    The display issue appears if the Post Limit is set to 9 or more… and if the number of posts available, according to the selected taxonomies, is higher than 8.

    Does the “preview” button within MetaSlider work?
    Yes it does.

    What if you add a new post so post #9 becomes post #10? Then is a post limit of 9 okay?
    Not sure to understand your question.
    Cf. First comment.

    Regards,
    Potoman

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @potoman,

    When you select 9 posts you are selecting 9 posts based on the query.

    {
    1:post 1,
    2:post 2,
    3:post 3,
    4:post 4,
    5:post 5,
    6:post 6,
    7:post 7,
    8:post 8,
    9:post 9
    }

    So if you create a new post, everything will be moved down by one slot:

    {
    1:new post
    2:post 1,
    3:post 2,
    4:post 3,
    5:post 4,
    6:post 5,
    7:post 6,
    8:post 7,
    9:post 8
    }

    **post 9** would no longer be in the set. This would fix your issue if post 9 has some improper data in it. If this is the situation, the everything would break when you set the post limit from 9 to 10 (after adding this post)

    potoman

    (@potoman)

    Hi kbatdorf (@kbat82),

    Additional comments,

    Comment 1
    In order to temporarily fix the display issue of my welcome, home pages,
    I have reduced the number of slides to be displayed in the first raw of slidershows (“Christmas” ones).

    When the sliders are configured with a number of posts to be displayed set to 8, the page is displayed correctly. But from time to time, there’s still am issue than can occur.

    So I set all the slidershows with a number of posts to be displayed set to 4, and the page is now displayed correctly, with a low risk of display issue.

    By the way, I have noticed something strange. Although all slideshows are configured with a number of posts to be displayed set to 4, one of them displays only 3, despite the number of posts available is of course superior.

    potoman

    (@potoman)

    Hi kbatdorf (@kbat82),

    Additional comments,

    Comment 2
    While trying to understand and investigating, I also discovered a second very strange thing.

    If you look at the second raw of sliders (3 sliders), you can see that slideshows displays 10 posts. Everything would be fine but:

    – like in the previous comment, one of them displays 9 instead of ten posts.
    – if I know look at the configuration of each of them, here’s what I can see regarding the Post limit:

    Latest Published : 4 (Instead of 10)
    Recommended Playlists: 1 (Instead of 10)
    Roulette: 10

    But if I look at any other metasliders, the Post limit initially configured is still correctly displayed in the front and the back end.

    Regards,
    Potoman

    potoman

    (@potoman)

    by the way, you can find the slideshows on the following page:
    http://www.potoclips.com/welcome

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @potoman,

    Does everything work as expected when you don’t use the page builder?

    If so can you just disable the page builder for those pages?

    Has their support provided any insight?

    potoman

    (@potoman)

    Hi kbatdorf (@kbat82),

    My answers below,

    Does everything work as expected when you don’t use the page builder?
    Yes, it seems. But I need to use Page Builder AND Metaslider. Everything were working fine between them since last week, after a simple save.

    If so can you just disable the page builder for those pages?
    I can’t. Page Builder is the basic structure of the pages. If I disable it, the page will be empty.

    How do you understand or explain,
    1 – that in the Metaslider interface, the Post limit setting is no more working or correctly displayed for all sliders embarked in a page designed by Page Builder ?

    2 – that for the first raw, (http://www.potoclips.com/welcome), I need to set the Post limit to 4 to limit the display issue at its maximum, while at the 3rd raw, the slideshows displays and are initially set to display 10 posts?

    Regards,
    Potoman

Viewing 15 replies - 16 through 30 (of 33 total)
  • You must be logged in to reply to this topic.