Support » Plugins and Hacks » Page Builder: After upgrade to 1.4.4 pages are blank

Page Builder: After upgrade to 1.4.4 pages are blank

  • Hi Greg,

    I downloaded Page Builder from your site yesterday in the morning and built some pages with it without any problems. Later on I saw that there was an update to 1.4.4 and I updated it. After that I couldn’t properly create new pages with Page Builder, they are just blank after editing. Also when I try to edit previously working pages built with Page Builder, they also get deleted/blanked.

    To add some more complexity to the bug: Sometimes the inserted text is modified in some weird way (e.g. there are suddenly “/n” strings in the text and some HTML tags are missing).

    Hope you can fix this soon, I really like your plugin.

    Best regards


Viewing 15 replies - 1 through 15 (of 39 total)
  • Btw: I’m only using the “Text” widget and use HTML in there.

    Plugin Author Greg Priday


    There are a few strange errors there. Do you by any chance have access to your server’s error logs? An error message would be a huge help in figuring out what the problem is.

    Also, if you could give me any of the following:

    * Your WordPress version.
    * PHP version.
    * A list of plugins you have installed.

    Currently no access to the logs, but I could get it if necessary. I also could give you temporary access as WP admin, if that helps.

    WordPress 3.8.1 (using your Vantage theme)
    PHP version 5.3.3-7+squeeze18
    MySQL version 5.1.72



    All In One SEO Pack
    Antispam Bee
    Category Order
    Easy Add Thumbnail
    Google+ Author Plugin
    Google XML Sitemaps
    Multiple content blocks
    NextScripts: Social Networks Auto-Poster
    Page Builder by SiteOrigin
    PS Disable Auto Formatting
    SEO Smart Links
    Statpress Visitors
    Ultimate Tag Cloud Widget
    WP Fastest Cache
    WP Multibyte Patch


    Acunetix Secure WordPress
    Advanced Menu Widget
    NextGEN Gallery by Photocrati

    I’d like to add a me too on this thread.

    Been struggling since 1.3.10 to update…every version I’ve tried gives me the same issue. On pages designed with PageBuilder, following the plugin update
    I get this blank PageBuilder box.

    This is pretty frustrating — I’d prefer not to have to completely redevelop all of my pages just to upgrade. I keep downgrading back to 1.3.10. My WordPress theme is Vantage Premium.

    Thanks so much for your help & hard work.

    This is looking like the same issue I reported as well. Every time I update an existing PageBuilder page it blanks out my text widgets.

    Though the widget still exists which is slightly different than tsinghua’s problem.

    Greg: have you tested modifying pages originally designed by a previous version?

    Just as a test. I created a page today with PB and published, then did similar moves/deletes of widgets and putting stuff in different rows…

    Everything is working ok on pages built and edited with this version of PB. If I modify a page built in a previous version, it breaks the page and clears out my panels.

    Plugin Author Greg Priday


    Hi @tsinghua.

    That looks like the Page Builder code isn’t loading properly. Can you try doing a hard refresh to make sure the latest code is loading.

    Windows: ctrl + F5
    Mac/Apple: Apple + R or command + R
    Linux: F5

    After that, can you check if you’re getting any Javascript errors. The same goes for anyone else getting this error. If I can track down the error that’s causing the Page Builder interface and content to not load, I should be able to fix it.


    @jezter6, yeah, I did do some testing with updating from older versions, but I’ll do some more testing. Maybe there is a specific situation that I missed.

    Hi Greg,

    no JS errors whatsoever.. only a warning that something is deprecated.

    I also tried disabling “Copy to Post” in the settings, like you suggested in another thread, to no avail.

    Here’s the result of my first round of searching for JS errors:
    From Chrome.

    Uncaught TypeError: Cannot call method 'replace' of undefined panels.admin.panels.min.js?ver=1.4.4:2
    $.fn.panelsCreatePanel panels.admin.panels.min.js?ver=1.4.4:2
    panels.loadPanels panels.admin.panels.min.js?ver=1.4.4:13
    (anonymous function) panels.admin.min.js?ver=1.4.4:4
    c load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:3
    p.fireWith load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:3
    x.extend.ready load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:3
    q load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:3

    From Firefox:

    16:45:13.877 Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. load-scripts.php:4
    16:45:14.029 TypeError: formHtml is undefined panels.admin.panels.min.js:2


    We are joining this thread, currently in development with Vantage Pro running a Child theme. WordPress 3.8.1, PageBuilder 1.4.4. This is a managed dedicated server, so I can’t easily tell you what Version of PHP we are running, but it should be very current. We get the same blank page when we hit the update button. Pages not built with PageBuilder update normally. Firefox throws plenty of warnings, but no errors.

    Plugin List:
    Black Studio TinyMCE
    Captcha Pro
    Contact Form 7
    Custom Post Widget
    Easy Social Icons
    Google Maps Widget
    Page Builder
    Recent Posts Widget Extended
    Responsive Add-ons
    Root Relative URLs
    Tiny MCE Advanced
    TW Recent Posts Widget (not in use)
    Wordfence Security
    WP htaccess control

    Plugin Author Greg Priday


    Thanks for the error messages tsinghua. It looks like what could be happening there is that some widgets give Page Builder a title that it doesn’t know how to handle.

    I’ve added some error checking. Can you see if this development version of Page Builder fixes the issue for you?


    You’ll need to delete the current version of Page Builder before installing this development version.

    Thanks for the help, Greg. I deleted Page Builder and installed the development version above.

    Still getting the exact same behavior from the plugin. Here is the error debugging from Chrome.

    Uncaught TypeError: Cannot call method 'replace' of undefined panels.admin.panels.min.js?ver=trunk:2
    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
    Uncaught TypeError: Cannot call method 'replace' of undefined panels.admin.panels.min.js?ver=trunk:2

    It’s an odd glitch, because I can open PageBuilder’s first level menus (to add widgets, columns, pre-built layouts) but when I click any of the options nothing happens.

    Here is the error code when I click one of the add widget buttons:

    Uncaught TypeError: Cannot call method 'replace' of undefined panels.admin.panels.min.js?ver=trunk:2
    $.fn.panelsCreatePanel panels.admin.panels.min.js?ver=trunk:2
    (anonymous function) panels.admin.min.js?ver=trunk:4
    x.event.dispatch load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:4
    v.handle load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:4

    I’ve tried disabling most of the plugins on the site, systematically. I’ll look into widgets into more depth.

    Plugin Author Greg Priday


    Would it be possible for you to create a temporary admin account for me so I can log in and take a look? If so, can you create it for greg@siteorigin.com


    Greg, I’m not sure if this is helpful, we can still make updates to our custom home page.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Page Builder: After upgrade to 1.4.4 pages are blank’ is closed to new replies.