Support » Plugins and Hacks » Facebook Instant Articles & Google AMP Pages by PageFrog » Pay attention to Google Webmaster Tools AMP Section!

  • Resolved gooma2

    (@gooma2)


    Many people haven’t realized that Google is requiring everyone to go through a 2-Tier system before their articles will be indexed by AMP…but Google is never much on great communication with the ‘common folk’.

    The biggest mistake many users of these AMP plugins are also making is that you have to keep an eye on your Google Webmaster Tools with the new AMP Accelerated Mobile Pages section. You will be able to see if your articles are getting indexed plus how many errors there are.

    As Google is slow, it can take 3-5 days for you to realize that there are any problems, and then another 3-5 days after fixing for them to be realized by Google.

    Sadly, we installed PageFrog and loved the fact that it really improves the look of your articles on AMP, but after three days, we noticed that that new articles published were redirecting to AMP properly, but the older articles were just redirecting back to the original link. I think we were so excited to have things working and looking good that we didn’t notice the problem for a few days.

    Then on Day 4 of installing PageFrog our Google Indexed AMP pages plummeted from 4K to 1K and then all the way down to 0 by Day 5.

    We did all the deactivating of the Yoast Glue plugin along with the AMP plugin just to see which one was causing the strange redirect issue, but sadly it kept coming up for PageFrog.

    Even after the developers updated it to turn off plugins that might raise AMP errors, the redirect problem remained.

    After keeping PageFrog deactivated for 4 days, our AMP indexed pages are back up to 4K. I’m still having our developer figure out what could be causing this as I think this is a great plugin for what it wants to do.

    If anyone else has had this issue with your AMP indexed pages dropping, let the developers know too as they are working hard to figure out fixes for so many of these issues that are beginning to rear their heads.

    Even the AMP plugin developers are realizing that there are way more issues beginning to crop up as this switchover is pretty big and there are so many moving parts.

    https://wordpress.org/plugins/pagefrog/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author pagefrog

    (@pagefrog)


    Hi gooma2,

    Thank you for taking the time to write this message and to help many other users on this forum. We’re working as fast as we can, all hands on deck, to investigate this redirect bug.

    Any information, error logs, or observations anyone can provide us will drastically speed up our progress on resolving this issue.

    So far, we’ve seen this happen to URLs ending in .php and .html, which is a starting point. We’ve also seen it working properly with .php and .html as well, so it’s at the very least an area worth investigating.

    With PageFrog and WP AMP plugins installed, the original page should include an “amphtml” tag which tells Google where the AMP page is. We’ve seen that this code is pointing Google to /amp, but for some pages the AMP page is living on ?amp=1.

    This is because /amp doesn’t work with all permalink settings. For example, http://example.com/?p=N/amp would not work since the /amp is appended after the ?.

    These are our discoveries so far and I’ll share our progress as we move along. This is our top priority at the moment and we’ve resolved several major bugs in the past relatively quickly, so I’m confident we can do the same with this one.

    We have been releasing major updates every 2-3 days to help publishers get on AMP as soon as possible. We’ll keep up this release schedule so please keep reporting any errors and bugs to us on the forum here or by email at team@pagefrog.com.

    We’re using the post name permalink

    https://movietvtechgeeks.com/sample-post/

    I can relay this to our developer also to see if he can find anything in this.

    We’re getting the “amphtml” tag showing up in the source code too.

    At least in 6 months all these issues will be behind us:)

    Possible hint on debugging:

    As I test AMP/PageFrog using a internal test server, I experienced permalinks not reflecting correctly. The test server (as does the livesite) includes 2 permalink plugins:
    – Custom Fields Permalink 2
    – Custom Post Type Permalinks
    These plugins permit dynamic custom field replacements and slugs for permalinks.

    With PageFrog enabled, permalinks were not replaced. The tokens were visible within the html canonical and amphtml tags.

    Resaving permalinks had no effect, but when I de-activated PageFrog and AMP, and then re-activated both, the replacement logic for posts and custom types began working correctly.

    That’s exactly what we had happen also. Because it’s such an odd thing where the newer posts will redirect perfectly and older ones don’t, most people don’t think to check on that.

    Our developer noticed it, otherwise we would have had no idea. On the Google Publisher Forum, there are others who had the same issue along with their AMP indexed links becoming de-indexed after activating the PageFrog plugin.

    Since Google is so slow to reflect errors on the Google Webmaster tools, it makes even harder to know when the error really began. On average, it’s about 4 days before Google will reflect changes (good or bad) so for the person that’s made several changes in that time, it will be a bit tougher.

    Plugin Author pagefrog

    (@pagefrog)


    Hello gooma2 and paul buxbaum,

    Breaking news!! We’ve resolved the permalink issue and it should definitely fix the issues you saw regarding AMP indexing.

    Previously, there was a discrepancy between where the “amphtml” tag was pointing towards, and where the AMP pages actually reside.

    We’ve resolved this error so that the “amphtml” tag is always pointing towards the appropriate AMP url.

    This fix has been included in 1.0.9 which we just released.

    One thing to note: you can check your validation without Google indexing your page.

    Just add “#development=1” to the end of an amp URL and then inspect with Google Chrome’s developer tools.

    Plugin Author pagefrog

    (@pagefrog)


    You can certainly use the “#development=1” to validate an AMP page, but it’s important to note that AMP validation is only one of the many rules Google Webmaster Tools requires to actually index the AMP page.

    For example, #development=1 will only report any AMP errors, but Google indexing will also check schema errors as well.

    Long story short, just because #development=1 shows that the AMP page is valid, it still doesn’t mean that Google will index the page.

    Another tool that could come in handy is Google’s Structured Data Testing Tool which will help you identify any schema issues https://developers.google.com/structured-data/testing-tool/

    Yup, it’s a 2 tier process for google so you check that but also check the Google Structured Data Tool as you have to pass both of those.

    Also remember that Google Webmaster Tools may take up to a week (usually about 4 days) to reflect changes or errors (good or bad) so testing is a lot different and a much longer process with AMP.

    Thanks for the update guys too!

    Great plugin. Only minus I see, it that it doesn’t include Custom fields in the AMP pages, which much of my content consists of, leaving parts on my page.

    Any idea how I can add this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.