WordPress.org

Forums

Multisite Language Switcher
[resolved] page association doesn't work (8 posts)

  1. Ateny
    Member
    Posted 2 years ago #

    If I associate a page of another domain via the metabox in "new post" section, the page reloads and it still doesn't have the association. it seem not to work with any page / post

    I have a WP MU via subdomains installation

    http://wordpress.org/extend/plugins/multisite-language-switcher/

  2. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Could you explain what do you mean with "a page of another domain". You see the drop-down with the posts of the other blogs, right? Do you have also different flags in the metabox like here: https://github.com/lloc/Multisite-Language-Switcher/wiki/Association-of-posts ?

  3. Ateny
    Member
    Posted 2 years ago #

    Exactly. When I load the page for the first time the box doesn't have anything selected by default (which I believe is correct). If I choose a page of another blog from the drop-down menu and click "Update", the page reloads without updating, but still shows with nothing selected.

    I wrote "a page of another domain" because I am using the plugin on a WP multisite installation configured to use subdomains. Which means: one blog is e.g. http://first.example.com and the second is http://second.example.com. The configuration page works fine, and I can add the blogs, thus being able to view the different pages in the drop-down menu, but the "Update" button doesn't work.

    Furthermore, it doesn't work the small flag used to create the translations.

    https://github.com/lloc/Multisite-Language-Switcher/wiki/Settings seems to work fine.

  4. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    OK, thanks. Could you provide a screenshot of the metabox in "Edit posts"?

  5. Ateny
    Member
    Posted 2 years ago #

  6. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    OK, thanks.

    The switcher looks for a configured language in the other blog. It seems there is no setup and that's thee reason you see the american flag. Please have a look at https://github.com/lloc/Multisite-Language-Switcher/wiki/Plugin-installation-and-activation (2. Choose the blog language).

  7. Ateny
    Member
    Posted 2 years ago #

    Now it works fine. Thank you!

  8. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, excellent.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multisite Language Switcher
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.